Web app opening incorrect map (multiple itemIDs in config.json)

455
2
06-16-2017 06:05 AM
JulieRoebotham
New Contributor III

I have created a map in web app builder in ArcGIS Online, then added it to a web app. After changing a few configs (colour, a few widgets) I then used the Save As functionality on the web app to save as a new name, and then repointed the map to a new map (using this method so i don't have to recreate the application configs - custom colour, widget placement - ever time i make a new app in the series). 

This was all working fine until suddenly a few of the web apps started opening the incorrect map, and all widget configuration was gone. I downloaded the apps into web app builder dev edition so i could look at the config.json, and i can see that for those maps the config.json is quite large (~27k lines) and references several different itemIDs. when i look at the itemIDs i can see they're the maps from the original application before i selected Save As and changed the map. 

I can recreate the multiple itemID issue by adding a widget such as the Attribute Table, or Near Me, which requires reconfiguration once you swap out the map for a new one. The multiple item IDs are in a section of the config.json called 'originConfig'

Is this expected behaviour? i'm assuming something has gotten messed up and the application is looking at the incorrect itemID when opening the wrong map. is Save As - swap out the map not a supported workflow? or is it expected that if you have to reconfigure widgets due to swapping out a map that it will retain the original itemID?

0 Kudos
2 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Julie,

   I have never used this workflow so I can't say I have any experience with this. But This does not sound like expected behavior. You should contact esri tech support and log a bug for this.

0 Kudos
JulieRoebotham
New Contributor III

Already on it  just wanted to check the herd and see if anyone has bumped up against it as well... thanks for the response!