WAB Dev Edition - Turned-on HTTPS Only in AGOL

255
8
04-09-2019 03:14 PM
DevonHedemark1
New Contributor III

Hello,

We have WAB Developer Edition on our local GIS server with a couple apps currently deployed.  Our internal GIS server has a trusted CA wildcard cert. (RapidSSL)

I recently turned on the "HTTPS Only" setting in our ArcGIS Online for organizations account.  But, since we turned on the ArcGIS Online setting of "HTTPS Only" , which stores the web maps used in WAB, I receive a certificate error?  When I attempt to continue to website, it shows my ArcGIS Online organization URL (with https://myago.maps.arcgis.com but then redirects me to the same page after signing-in.  I am no longer able to reach my app page.

I have seen a couple threads related to this issue, do I need to complete these steps?

https://www.esri.com/arcgis-blog/products/apps/announcements/enable-web-appbuilder-for-arcgis-develo...

My registered app URL in ArcGIS Online is http:// but has registered redirect URLs containing the https versions of the URL.

Devon

0 Kudos
8 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Devon,

   When you go all https then you have a lot of work to do to change all urls you are using in your app and webmaps to use https urls instead of http. In your WAB apps you need to go into the main config.json and change the PortalUrl to https. In all your webMaps you need to update urls to now use https. This can be dones fairly easily with ArcGIS Online Assistant

DevonHedemark1
New Contributor III

Good morning, Robert

Thanks for the response.  I feel pretty confident that all the web maps in my 2 WAB apps are using HTTPS.  But, I can check those again.  I have not made any config file changes though.  I will make those changes for the 2 apps. 

I see the Portal URL in the config.  It lists my AGO URL in the config as http as well.  Should I change all those references to https?

If I change the config file for both my WAB apps (i.e. 3, 4) do you feel that change alone should allow the WAB app page to load so I can edit my apps, without changing any certs?  Per the article linked above WAB installs with local trusted certs.  I have a signed cert on my GIS server, but not specifically for the WAB launch URL which launches as http as shown below.

I appreciate your assistance as always.

Regards, Devon

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Devon,

   Yes change the potalUrl in the main config.json then when you launch that app it will automatically use https.

DevonHedemark1
New Contributor III

Hi Robert, 

Great, thanks.  I changed the URL's but it still loads as http when I launch startup.bat, and after specifing my AGO and signing-in, it just redirects back.   Do I need to change this reference in the config?  

"httpProxy": {
"useProxy": true,
"url": "/proxy.js"
}
}

Also, should I change http references in the config.json under stemapp and stemapp3d?

Regards, Devon

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

No leave those alone.In the server folder change the url in the signininfo.json file. Then your whole WAB app will stat using https.

DevonHedemark1
New Contributor III

I made those changes and have the same issue.

Upon launch of startup.bat, it still loads as http, then seems to redirect quickly to https:, presents a certificate error, I continue, confirm AGO URL (w/https:)/green check mark, sign-in, and I'm taken to the same AGO URL page.  I can't seem to access the apps.  I appreciate the help.

Regards, Devon

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

This is something best handled by tech support then since they can do a screen share and diagnose the issue better.

0 Kudos
DevonHedemark1
New Contributor III

Hi Robert,

I contacted Esri.  They confirmed the change as you advised in the signininfo.json file. 

We were able to paste the WAB URL in Chrome and it worked fine to see the apps.  So at least I can edit my apps in Chrome.  They all function fine on the web so my immediate issue is resolved.  We tried some IE setting changes (i.e. un-check enable advanced protection under security) but that did not get WAB functioning in IE.  I may pursue the trusted CA cert but at least it is resolved with Chrome for now.

Regards, Devon

0 Kudos