WAB 2.8 App With HTTPS

340
1
06-25-2018 11:16 AM
JulianoZaban
New Contributor

Hello All!

I configured a small application with Web AppBuilder 2.8 in my localserver (http://localhost:3344/webappbuilder) and then I  deployed it in our web server. 

When I access this application with HTTP, everything works fine, but when I use HTTPS the folowing error occurs:

TypeError: Cannot read property 'toLowerCase' of undefined
at Object.mo.addProtocol (basePortalUrlUtils.js?wab_dv=2.8:167)
at Object.mo.setHttpsProtocol (basePortalUrlUtils.js?wab_dv=2.8:237)
at Object.mo.setProtocol (basePortalUrlUtils.js?wab_dv=2.8:245)
at Object._changePortalUrlProtocol (ConfigLoader.js?wab_dv=2.8:736)
at Object.<anonymous> (ConfigLoader.js?wab_dv=2.8:799)
at init.js:63
at c (init.js:103)
at b.extend.then.B.then.then (init.js:105)
at Object._processNotInPortalAppProtocol (ConfigLoader.js?wab_dv=2.8:794)
at Object.<anonymous> (ConfigLoader.js?wab_dv=2.8:139) "TypeError: Cannot read property 'toLowerCase' of undefined

... (continue with tons of messages)

Anyone experienced something like this?

Ps.: I'm using ESRI Proxy Resource .Net version for authentication in secure services (ArcGIS Server security).

Thanks!

Juliano

Tags (1)
0 Kudos
1 Reply
deleted-user----ypwdOWHsd
New Contributor III

I just ran into this. You can't clear out the "url" property completely. Instead, just set it to the empty string:

Example:

  "httpProxy": {
    "useProxy"true,
    "alwaysUseProxy"false,
    "rules": [
      {
        "urlPrefix""...",
        "proxyUrl""..."
      }
    ],
    "url"""
  }