WAB 1.1 - Download 4 Deploy; itemid old value; widget missing

2549
3
09-01-2015 03:21 PM
Ravichandran_M_Kaushika
Occasional Contributor

dear Readers,

thank you for taking the time to read this post and contemplating potential solutions for the same:

Situation. We have a web app builder 1.1 - the application consumes a map on a portal 10.1.  We made changes in the past and used download button to get the latest code and publish to the servers.  It was working fine.

Recently, we made modifications to the portal server that contained the main map that resulted in modifying the itemId value in config.json -

http://myServerName.Domain.com/arcgis/home/webmap/viewer.html?layers=0a7d2f5a8cfe4babbe113ec5c9cd546... - this value.

To start with, we had changed the itemId value of config.json file in the web app builder environment  to use the same underlying map from the portal - but with the new ItemId.

Now problems encountered are as follows:

1. when we download from a working WAB for deploy - downloaded code  remembers the old itemId and not the new one even though the code folder under the WAB folder structure has the new itemId in config.json.  So we had to manually change the itemId everytime before copying the contents from the download zip/unzip folder to the server location.

2. Any new widgets that were create after the 'itemId' change are not showing in the published app  on the server but not on the WAB launch menu.

2b. On the server version, we see WIDGET TEMPLATE where we had mad changes.  On doing a file search on the download 4 deploy zip/unzip folder, we could see the html / javascript changes that are working on WAB launch menu.  The code on the server contains the new html controls and javascript code - but they would not show up.

any input to resolve our current situation would be great.

regards

ravi

0 Kudos
3 Replies
JunshanLiu
Occasional Contributor III

In WAB developer edition, all related files are copied into app folder when an app is created. When download an app, a new zip file is created under apps/zips/<appid>.zip. If the zip file exists, the following download request will use this file instead of create a new one.

So, you can remove the zip file and then try to download again.

0 Kudos
Ravichandran_M_Kaushika
Occasional Contributor

Junshan Liu,

good afternoon. sorry for the delay in responding to your reply. Perfect answer.

Can you request an enhancement request for the application to delete this zip or create a new one with time stamp to distinguish the zips generated.

I spent 2 days trying to see whether I had done something wrong.

regards

ravi.

0 Kudos
JunshanLiu
Occasional Contributor III

Thanks for your feedback, we'll try to figure out a way to avoid this issue.

When you edit and then save an app, the related zip file will be deleted. If you want to edit an app out of WAB, I suggest you import the app after editing.