splash widget problem

5947
5
01-29-2015 09:34 AM
LonSharp
Occasional Contributor II

I'm new to web appbuilder, so please bear with me....

I've created my first app in web appbuilder which includes a disclaimer in the splash widget.   I've turned on the widget and when I click on the "Launch" option to make sure it works, everything looks good.   The splash page comes up with the disclaimer, and everything works the way I want it to.

ArcGIS Web Application

The problem is that I want to make this application available to everyone without the need for an arcgisonline account.   As I understand it, to do that I simply replace the first part of the url with http://www.arcgis.com/....    When I do that, the app comes up as before and works fine, with the exception of the splash page.   It never shows up.

ArcGIS Web Application

Am I missing something?   Does that particular widget only work within an organization and not on the www.arcgis.com end of things?

Thank you!

Tags (2)
0 Kudos
5 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Lon,

   The disclaimer came up for me using both links.

Edit: They both came up the first time I went to the links. And when I cleared the Cache they both would bring the splash up again.

LonSharp
Occasional Contributor II

Cache.   I should have known.   After years of dealing with cache issues in Flexviewer, that should have been the first thing I thought of.

So I cleared cache, and sure enough, there it is.   The problem now is that when I refresh or leave/return to the app, it's loading from cache and the splash doesn't show up.

Any thoughts on how to deal with that?   I need it to come up every time, not just the first time a user accesses the application.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Lon,

  Looking at the splash widget code there is a cookie stored when you click the accept and then ok so that it does not reappear. If you uncheck the require confirm check box in the widgets UI then this will not occur. If they do not check the "do not show again" checkbox.

If you are using the Developer version then this is a quick fix. In the Splash/widget.js (either replace the startup function with this code or just comment out the same lines as below).

     startup: function() {

        this.inherited(arguments);

        this._normalizeDomNodePosition();

        this.resize();

        if (this._requireCinfirm) {

          html.addClass(this.okNode, 'disable-btn');

          html.removeClass(this.okNode, 'enable-btn');

        }

        this.own(on(window, 'resize', lang.hitch(this, function() {

          this.resize();

        })));

        /*if (!TokenUtils.isInConfigOrPreviewWindow()) {

          var isfirst = cookie('isfirst');

          if (isfirst === 'false') {

            this.close();

          }

        }*/

        this._resizeContentImg();

      },

LonSharp
Occasional Contributor II

That's strange.   If I leave the "Require confirmation to continue" box unchecked (this is the non-developer configuration page), the user is presented with a check-box for "Do not show this splash screen again".

If I check that box, I can set the text (default is "I agree to the above terms and conditions"), the result is basically the same.   The only thing that changes is the text alongside the check box.

Either way, if the use checks the box, they don't get the splash screen again, which seems kind of useless.

So I guess I'll need to download the developer version, which I'd been hoping to avoid.

Thanks yet again, Robert.   I'll tackle this tomorrow.   I may be back to have you clarify exactly what I need to do.

0 Kudos
JosephRathvon
New Contributor III

Thanks I found this helpful.  In the 1.3 version of the splash widget there is the same block of code in the on open  section that I needed to comment out to get it to display every time as well.

0 Kudos