Related Tables not editable/viewable

1257
6
02-25-2017 01:58 PM
MeleKoneya
Regular Contributor

I have an SDE feature class and an SDE Table that have a relationship class in SDE.   I can add related table records and edit them in ArcMap.

I published the MXD as a map service and then created an AGOL web map.   I can see the related records in my web map on AGOL.

When I go to Web AppBuilder (Developer Edition) 2.3 and use the edit widget,  I don't see the related table records nor do I see them when viewing the attributes.

Is there something I am missing in the configuration to get this to work?

Thanks,

Mele

0 Kudos
6 Replies
MeleKoneya
Regular Contributor

It was something simple that I was overlooking.    I needed to add my related table to my AGOL web map.   The related table is now editable in Web AppBuilder.

Mele

0 Kudos
RyanBoudreaux
New Contributor II

I'm having a very similar problem. I have the related table in my map, and everything is viewable/editable in Web AppBuilder for AGOL.  My problem happens when I use Web AppBuilder (Developer Edition).  When I download the created app and deploy it on a webserver, I can't view/edit the related table data in the same way I can in AGOL.  Do you have any other ideas?  Any help would be great. web appbuilder2.3 #wab developer edition 2.3

MeleKoneya
Regular Contributor

Ryan,

The way I resolved my issue was to add the related table to my web map.    

As far as the issue you are having,  is it with editing?    Can you add features or not?     You may have to add a proxy on the machine hosting your local version of the Web AppBuilder application if you are using ArcGIS map server layers in your web map like we are.

Mele

0 Kudos
RyanBoudreaux
New Contributor II

Mele,

Thanks for the suggestion.  All the data is stored in AGOL.  Yes, I can edit the feature the table is related to, but not the related table data.

0 Kudos
JakubSisak
Regular Contributor

A bit late to reply to your comment, but I seem to be having the same issue. I have created a hosted feature layer (using an esri template just to be sure it's not just my data) in both AGOL and ArcGIS Portal, and I can't get the current version of the Web AppBuilder Developer edition to show the related tables. They don't appear in either the popup or the edit window. It works fine with the built-in version of WAB in AGOL, just not the developer edition which is very frustrating. Have you had any luck or filed a bug with ESRI?

0 Kudos
MeleKoneya
Regular Contributor

Ryan,

I am not sure about hosting the data (feature class and related table) in AGOL.      I am doing everything in my ArcSDE database (Feature Class, Related Table, Relationship Class)

I did find this article.

FAQ: Does ArcGIS Online support joins and relates? 

Mele

0 Kudos