Popup window behaviour for a layer inside a WAB App

1271
9
Jump to solution
09-29-2016 06:42 AM
SvivaManager
Occasional Contributor II

Hello,

I notice a strange behaviour for the option to enable popup windows for layers in an app which I created with the WAB.

I have an app that reads a WebMap, which contains some layers from the portal and all those layers are map services are represented as an MXD Project for a lot of layers, so there the layers are divided into many groups inside.

I know there is an option to enable each layer a popup window separately, through the webmap editor screen.

There is also an option to enable the users to choose which layer to enable a popup window or disable it, all done through the small menu options next to the layer name in the layers widget of any WAB app.

The weird thing is that some layers enable that option and some don't even show this option available.

I've attached screenshots for example - One screenshot shows the menu options with the option to turn on the popup window, the other screenshot shows nothing but a "description" link for the direct rest address.

Anyone knows on this behaviour and can explain it?

Regards,

Shay.

0 Kudos
1 Solution

Accepted Solutions
SvivaManager
Occasional Contributor II

I was able to solve the problem by creating a new App with the WAB Dev Edition in it's new version (2.2).

Each new WAB Dev' Edition I moved all previous apps to the new version and it dragged my mentioned error along all versions. By creating the app all over, the problem was solved.

View solution in original post

9 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Shay,

   Do you have the popup enabled for that layer in the web map that is only showing the description menu option?

0 Kudos
SvivaManager
Occasional Contributor II

Hi Robert,
Yes I have just verified it. I enabled the pop-up and still the menu options for that layer shows only the description option - even if the pop-up isn't enabled, once the longer menu shows up, it enables the user to activate or deactivate the popup by himself

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Shay,

   What is the layer type for those that do not show the menu. There is logic in the code that determines if a layer supports a popup and if it does then it add that option to the menu.

0 Kudos
SvivaManager
Occasional Contributor II

The two examples are both map services items - not a direct feature layer item.

Those services are huge with lots of groups inside. Are you asking for the type of layer in the MXD file?

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Sviva,

   And you are sure that you are not trying to enable a popup on a group layer object and not the actual layer itself?

0 Kudos
SvivaManager
Occasional Contributor II

Positive. I keep clicking the items until I see the symbology to make sure it's a layer. Might be a bug I'm not sure.

Different behaviour for different services. I also checked to see if the service is enabling query in its server setting.

When using the service in the map screen of the portal, I get all the options, including popup window.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Sviva,

  Sounds like a bug then. Best bet would be to call esri tech support and see if they can re-produce this.

SvivaManager
Occasional Contributor II

Thanks Robert.

Shay.

0 Kudos
SvivaManager
Occasional Contributor II

I was able to solve the problem by creating a new App with the WAB Dev Edition in it's new version (2.2).

Each new WAB Dev' Edition I moved all previous apps to the new version and it dragged my mentioned error along all versions. By creating the app all over, the problem was solved.