No Basemap Choices in WebAppViewer

6821
25
Jump to solution
12-23-2014 11:00 AM
AdamRepsher
Regular Contributor

When I configure the Basemap Gallery Widget in the Web AppBuilder for ArcGIS‌, the basemaps are not available in the Web App Viewers.  I have tried this in current versions of IE10, Chrome and Safari (iOS).

I have a basemap gallery group that I have configured in our Organization, if that matters.

Is anyone else having problems making the basemaps appear for the web app viewer?

Reply
0 Kudos
1 Solution

Accepted Solutions
StanMcShinsky
Regular Contributor

I just tried this and it worked for me:

1. In a separate tab enter one of the following URLs

          ---www.arcgis.com/sharing/rest/content/items/<itemid>/data?f=pjson         

          ---<orgkey>.maps.arcgis.com/sharing/rest/content/items/<itemid>/data?f=pjson

Change the <itemid> and/or <orgkey> for the Web Map id

2. Open the details of your web mapping application and click edit.

3. At the bottom change the purpose to Configurable.

4. Copy the json text from step 1 and paste it in the Configuration Parameters section at the bottom.

5. Edit out the empty json tag that is in the basemap gallery section that looks like {},

6. Save and refresh and that should do it.

View solution in original post

25 Replies
LemaoWu
Esri Contributor

Do all  basemaps in your basemap gallery group have different spatial reference from the current map you are using?  The widget only displays the basemaps sharing the same spatial reference as the web map loaded in the Web AppBuilder.

A note from the help doc:

Basemap Gallery widget—Web AppBuilder for ArcGIS (Developer Edition) | ArcGIS for Developers

AdamRepsher
Regular Contributor

All of the base maps are of the same spatial reference as the Esri base maps.

Reply
0 Kudos
larryzhang
Regular Contributor

Our basemap is different from ESRI Public basemaps, which is local projected SR, but still accessible to WebAppViewer (above)...

Reply
0 Kudos
larryzhang
Regular Contributor

Adam,

If the custom web map (a basemap for your organization) available, it looks that you can pick it up from the following path (below)...

web-map.PNG

web-map2.PNG

Reply
0 Kudos
deleted-user-YYhuCJuuEn9L
New Contributor III

I was having the same problem. There seems to be a bug where empty base maps are added to the list in the config file. By removing the empty base map JSON objects in the config, the issue was resolved for me.

AdamRepsher
Regular Contributor

Ryan Bosley wrote:

I was having the same problem. There seems to be a bug where empty base maps are added to the list in the config file. By removing the empty base map JSON objects in the config, the issue was resolved for me.

Can you tell me how to access the config file of the WebApp in AGOL?

Thanks!

-_Adam

Reply
0 Kudos
StanMcShinsky
Regular Contributor

If you are not using the developers version of WAB then here is another route.

Download app—Web AppBuilder for ArcGIS | ArcGIS

Follow the instructions to deploy the app.

Download the app link here http://www.arcgis.com/home/item.html?id=fffd70b754594c54bc58d90d4e897e19

on step 2 add that url (www.arcgis.com/sharing/rest/content/items/<itemid>/data?f=pjson or <orgkey>.maps.arcgis.com/sharing/rest/content/items/<itemid>/data?f=pjson) to your browser and input your app id from AGOL (the long number at the end of your map url).  here is where you can access that config file and get rid of the empty JSON tags  (towards the end of the file).

AdamRepsher
Regular Contributor

Thank you for the suggestion Stan.

My problem remains because I want to have this app available in ArcGIS Online‌.  Since you gave me a workaround, I am assuming that I cannot manipulate the app code in AGOL directly.  Correct?

So, I am also assuming that this is a bug in the AGOL version of Web AppBuilder for ArcGIS‌.

--Adam

Reply
0 Kudos
StanMcShinsky
Regular Contributor

I just tried this and it worked for me:

1. In a separate tab enter one of the following URLs

          ---www.arcgis.com/sharing/rest/content/items/<itemid>/data?f=pjson         

          ---<orgkey>.maps.arcgis.com/sharing/rest/content/items/<itemid>/data?f=pjson

Change the <itemid> and/or <orgkey> for the Web Map id

2. Open the details of your web mapping application and click edit.

3. At the bottom change the purpose to Configurable.

4. Copy the json text from step 1 and paste it in the Configuration Parameters section at the bottom.

5. Edit out the empty json tag that is in the basemap gallery section that looks like {},

6. Save and refresh and that should do it.

View solution in original post