My Location widget grayed out on Android

1707
5
Jump to solution
09-27-2016 06:04 AM
ErikBlake
Regular Contributor

I was wondering if anybody has run into the issue of the "my location" widget becoming grayed out when using an app built by web app builder on an android tablet. I checked on my iPad and it works fine. So I don't think it is the application itself. I have gone in to the settings and made sure location settings was all good and all the usual trouble shooting stuff. It was working, and it became grayed a couple of days ago so not sure what happen. Just seeing if anybody ran into this before

1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

Erik,

   That is by design. If your site does not use the https protocol then the my location widget will be disabled. To fix this your site has to use ssl (https protocol).

There are security considerations to be taken into account when working with geolocation. Each web browser handles security differently. For example, if working with a later version of Chrome, you must host it via HTTPS. If hosted via HTTP, the application will load minus the Locate widget button. Although for testing purposes, it is still possible to host via http://localhost. For additional information regarding these security considerations, please see the ArcGIS blog, Increased web API security in Google Chrome.

View solution in original post

0 Kudos
5 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Erik,

   That is by design. If your site does not use the https protocol then the my location widget will be disabled. To fix this your site has to use ssl (https protocol).

There are security considerations to be taken into account when working with geolocation. Each web browser handles security differently. For example, if working with a later version of Chrome, you must host it via HTTPS. If hosted via HTTP, the application will load minus the Locate widget button. Although for testing purposes, it is still possible to host via http://localhost. For additional information regarding these security considerations, please see the ArcGIS blog, Increased web API security in Google Chrome.

0 Kudos
ErikBlake
Regular Contributor

Robert

Thanks for the insight. Just out of curiosity why does it work on my iPad and not the android then, we are using the same browser on each tablet?

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Erik,

   If you have iOS 10 on your iPad then it will not work either using safari. If you are using chrome on the iPad it should be disabled as well. But if you have an older iOS and use safari then it will still work.

ErikBlake
Regular Contributor

Robert Nevermind It is probably cause I am running older version of chrome. Thanks for your help

0 Kudos
MatthewKing
Occasional Contributor II

I don't know if you still have this issue, but I had the same problem and what solved it was adding a "s" to the end of the http.   http -> https

0 Kudos