My location not working on iphone

1142
6
01-26-2017 10:24 AM
by Anonymous User
Not applicable

Hi all,

I am trying to test on an iphone my location but I get no results. No highlights, no markers, no zoom to desired scale.

Any idea?

Tags (1)
0 Kudos
6 Replies
DerekLaw
Community Moderator

Hi Alex,

Are you using wifi or your iPhone cellular service?

Are you connecting with HTTP or HTTPS?

Which IOS release?

Can you please contact Esri Tech Support and log an issue? We've had a couple of other similar reports, but we can't seem to get a definitive repro case to investigate further. \

Thanks,

0 Kudos
by Anonymous User
Not applicable

I am using HTTPS. The privacy settings is set to while using. I am using ATT LTE service. I am using 10.2. I am about to upgrade to 10.2.1.

0 Kudos
deleted-user-CQZbjNeBXm49
Occasional Contributor III

Hi Alex,

The geolocation event for WAB do not work on some browsers in http but on https or even on neither, see here (http://caniuse.com/#search=geolocation) for more info on that.

Hope it helps

Baba

0 Kudos
EmilyLee2
New Contributor III

Hi Derek,

Do you know if this is a known issue with iPhone?  Because my https GeoForm works fine in Android devices, but not on any iPhone devices.  Here is the GeoForm:  https://arcg.is/1zPTzq

Thanks,

Emily

0 Kudos
DerekLaw
Community Moderator

Hi Emily,

I believe this was recently noted as a known limitation with IOS.

Please see this GeoNet post by agup-esristaff for more details,

https://community.esri.com/people/agup-esristaff/blog/2015/05/11/using-a-secure-origin-with-browser-... 

Hope this helps,

0 Kudos
EmilyLee2
New Contributor III

Thank you, Derek!

0 Kudos