Multiple Layer for symbology choices causes Filter pain

506
7
08-02-2017 04:11 PM
MichaelRobb
Regular Contributor II

Hi everyone,

Business wants to be able to represent (symbolize) the 'same' data multiple ways.  Currently this can only be done by adding multiple layers with the different symbology (all pointing to the same data).  Or is there a way I've overlooked? 

The downfall to making mutliple layers is now the layman user would either need to know to apply the separate filters based on the layers they choose for symbology, creating duplicate filters.

But wait... there is a Group Filter Widget.... but wait... this clunky awful widget just doesnt sit well with users.

Is there any ideas, direction, code snippits to rig up the FILTER widget (not the group one) to point to multiple layers (which look at the same featureclass - so schema is the same).  The Filter widget can be setup where as the user simply clicks on their options... (e.g. seen below can click on Low Battery and Bad Health)  The user doesnt want to bother 'Adding criteria' like in the Group Filter), nor does group filter have the user ease as the Filter widget.

I'd love to hear options, thoughts or alternate approaches to this (exception of JavaScript API of course) but to keep this in WABde.  Thanks

Group Filter:

Filter:

Other widgets such as Info Summary widget is handled by pointing it to a hidden featureclass that has ALL records visible in the REST service

7 Replies
RickeyFight
MVP Regular Contributor

Here is a less clunky option for a group filter widget.

GitHub - daFiter/localLayer_filter: Esri Web AppBuilder filter Widget 

0 Kudos
MichaelRobb
Regular Contributor II

Thanks Rickey,

First Id like to comment on that link specifically..

Doesnt seem to work with WABde 2.5, even though the Read me has a comment of that it might..... tried commenting out as written.

Can anyone verify workable with version 2.5?

And the instructions/How to are atrocious from this forked version... (document / procedural skills gets a D-)

And to boot... the sample online has errors and does not load.  (ref: http://gis.ashland.or.us/demo3/ )

Searched for another version...

Using the 2.2 version... seems to work at first running on WABde 2.5, but then... you can never get out of the configuration window... pressing OK, does nothing, cancel, the upper right X... the user can only leave the page, ever able to save the configuration Spun up WABde 2.4... same issue. 

WABde 2.2 has way too many bugs to resort to that level.

Searched more... found a new 2.5 version 

ref: GitHub - cmndrbensisko/LocalLayer at LocalLayer2.5 

and the unfortunate same things occurs... unable to EXIT the configuring of the widget without killing the session.  Click on OK, you see the widget appear on the header, but the dialog does not disappear. Hit again and it say, 'Label Already exists'.  The upper right X does nothing and Cancel does nothing.  

Some issue with the table seems to occur:

I will do further investigating on this when I can...

Any comments appreciated.

0 Kudos
RickeyFight
MVP Regular Contributor

I just added my version of the widget to WAB 2.5 and it works as intended. 

I can look at the code and see what is different between the two. 

ArcGIS Web Application  Works for me Try it again 

0 Kudos
MichaelRobb
Regular Contributor II

Tried the demo in I.E., worked!  Tried again in Chrome, failed to load.  Rebooted machine.. now works (unknown cause).

Can you provide a link for the version you are using to get this to work in 2.5?

Thanks

0 Kudos
RickeyFight
MVP Regular Contributor

Michael Robb‌ 

Here:

Filter_Demo.zip

I took out my service name and left the spot where you need to add yours in widget.js

MichaelRobb
Regular Contributor II

Greatly appreciate the shelled Widget.

0 Kudos
RickeyFight
MVP Regular Contributor

Did you get it to work for you? 

0 Kudos