Login issues Custom WAB App Enterprise 10.9.1

2437
8
Jump to solution
02-28-2022 05:57 PM
Labels (1)
Grant-S-Carroll
Esri Contributor

Hi There

We have noticed an issue with custom web appbuilder applications that are accesing private webmaps on ArcGIS Enterprise 10.9.1. 

Initially we were having issues with the login loops have that have been documented elsewhere, we have resolved that issue, but now when loading an app we are presented with the follow flow.

First we get box that asks us to login to Enterprise.

 

GrantSCarroll_1-1646099411745.png

 

Once we click ok, we are presented with the standard login box.

GrantSCarroll_2-1646099453185.png

In the past and at 10.8.x we only recieved the second dialog box for logging in, the change seems to have occured with either 10.9 or 10.9.1 (I can't be certain as we had people who skipped 10.9 for 10.9.1). My question is, is this expected? Is there a work around to remove the first dialog as its a bit confusing for users.

My application is registered and the appId is in the configuration. 

It may be a red herring, but when viewing the network traffic I see a call to /platformSelf, which is returning an invalid client_id error. My understanding is that platformSelf is only to be called by apps that are hosted within ArcGIS Online or ArcGIS Enterprise, this is not hosted in either of those, only using a private web map from Enterprise, so I'm trying to understand why this is being called, as it looks like the last call prior to the first blue dialog being opened. 

Any ideas or help would be appreciated. Note this was on a legacy app (WAB 2.11), but I have also created a new custom app using WAB 2.23 and I get the same behaviour.

Thanks

1 Solution

Accepted Solutions
Grant-S-Carroll
Esri Contributor

Following up on this issue, and many thanks to Roger Clavero at Esri BeLux for providing the work around for this.

The above is the expected out of the box behvaviour. However, it can be overriden by doing the following in the application. 

1. In the downloaded application, navigate to jimu.js folder > tokenUtils.js.
2. Search in the file for the "popup: true" in the OAuthInfo class initialization.
3. Change the value of popup to "false"
4. Save the file
5. Now test the deployed application, it should redirect to the SAML login page without any popup

GrantSCarroll_0-1648149456104.png

 

 

 

View solution in original post

8 Replies
KamilNovák
New Contributor III

We observe the same behaviour. Enterprise 10.9.1, WAB Developer 2.23.

0 Kudos
Grant-S-Carroll
Esri Contributor

Following up on this issue, and many thanks to Roger Clavero at Esri BeLux for providing the work around for this.

The above is the expected out of the box behvaviour. However, it can be overriden by doing the following in the application. 

1. In the downloaded application, navigate to jimu.js folder > tokenUtils.js.
2. Search in the file for the "popup: true" in the OAuthInfo class initialization.
3. Change the value of popup to "false"
4. Save the file
5. Now test the deployed application, it should redirect to the SAML login page without any popup

GrantSCarroll_0-1648149456104.png

 

 

 

RogerCLAVERO
Esri Contributor

Credits to Darshan Kadam from Esri. Thank you, Darshan!

Roger Clavero - Esri BeLux.

AllenovDmitriy
New Contributor II

Thanks for advice!

This solution removes the first "Sign In" popup, but how to disable the next "Request for Permission" popup?

0 Kudos
hg2
by
New Contributor

Did you ever got a response? I am running into the same issue.

0 Kudos
hg2
by
New Contributor

Thanks for posting this! 

How can we disable the second popup where it asks to allow or cancel?

BrettLessner
Occasional Contributor

I was also having this issue and came across this bug: https://support.esri.com/en-us/bug/the-saml-login-fails-in-a-deployed-arcgis-web-appbuilde-bug-00014...

@Grant-S-Carroll's workflow did not work for me, but the workaround in the bug did. 

0 Kudos
BrettLessner
Occasional Contributor

Never mind, this sent the sign in into a loop.

0 Kudos