LocalLayer widget in WAB v2.8

643
15
05-11-2018 07:09 AM
GarrettMcBride
New Contributor III

Has anyone had any luck getting LocalLayer widget to work in any version higher than 2.5?  I see the latest version of the locallayer widget is v2.5 and wondering if that version is intended to match the WAB version?  When following the steps on WAB 2.8 I cannot get it to load from the default.  However, loading the widget to an app that was already created in (WAB 2.8) i am able to get the widget to load and also connect to rest services correctly.  The problem is that now the data loads but it hoses all the other widgets and WAB.  I was just wondering if anyone has ran across this or knows of any plans/workaround to use in a later version of Web Appbuilder.

0 Kudos
15 Replies
DanielMarulanda
New Contributor

I had. Just modify the library to use the legacy formulas. Some of them are deprecated but it's a fast fix.

0 Kudos
GarrettMcBride
New Contributor III

Thanks for the quick response, I am going to give that a try.  Did you reference 2.5 or 2.4? 

0 Kudos
DanielMarulanda
New Contributor

You have to change this files in the library llw.js

And you have to uncomment some code in Jimu/LayerInfos.js

0 Kudos
GarrettMcBride
New Contributor III

There is a new release of the LocalLayer widget and it works as advertised!

0 Kudos
TimHayes
Regular Contributor
0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Tim,

   Use this url for the 2.8 release candidate:

GitHub - cmndrbensisko/LocalLayer at LocalLayerv.2.8 

0 Kudos
DanielMarulanda
New Contributor

Is not working for me. It keeps loading the widget forever.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Daniel,

   Does the browser web console show any errors?

0 Kudos
DanielMarulanda
New Contributor
Error
columnNumber: 13
info: Array [ "/webappbuilder/apps/4/widgets/LocalLayer/setting/CustomLayerEdit.js?wab_dv=2.8", error ]
lineNumber: 11
message: "scriptError"
src: "dojoLoader"
__proto__: Object { }
0 Kudos