LayerList in WAB DE 2.11 not working

1081
6
Jump to solution
02-26-2019 03:59 PM
TimHayes
Regular Contributor

I installed WAB DE 2.11 along with the LocalLayer Widget (version 2.5). I seem to have no issues building an app, except when I go Launch and then this is what happens:

1) If I Launch it in IE 10, IE 11, or Chrome, the map appears in a separate tab, shows but does not get any further with the launch icon (those bars you see when you first launch an app, its right after the map appears that the launch icon keeps spinning and spinning and spinning) in the map window keep spinning. I am using HTTP, not HTTPS. I do not have an HTTPS site (not yet anyway, will soon). The app works good in FireFoxx except for item #2 below. 

2) In FireFox, after I launch the app, I click on the LayerList and Legend icons (upper right corner of the Map Window) and nothing happens. I should click on them and they expand showing the Layers I added. Is this a bug with 2.11? When I go into theWidgets Panel and check the LayerList Widget, I see all the default boxes checked, and the "Choose Which Layers Will Be Shown On The List" box as empty. Should the Layers I added to the app be showing here?

Could this be an issue with me using the LocalLayer Widget 2.5? (2.5 seems to be the most recent LL version)

Any assistance will be appreciated. 

thanks,

Tim

0 Kudos
1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

The chrome error will go away as soon as your add the woff and woff2 mime types to your IIS.

Set mime types for web fonts in IIS » Coding Still 

The llw.js I sent you is my mods to the file to fix the errors you were seeing. 

View solution in original post

6 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Tim,

   Do you see errors in the browsers web console if so please provide a screenshot.

0 Kudos
TimHayes
Regular Contributor

Here is the console errors I get when using IE 11, Chrome, and Firefox. 

This is from IE 11:IE 11 Console Error(s)

This is from Chrome:

This is from Firefox:

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Tim,

   OK those are the errors I was expecting. Replace the llw.js file in your app and stemapp widgets/localLayer with the one attached here.

TimHayes
Regular Contributor

Great work, Robert! this helps. Here is where I stand now:

First a correction, I am using IE 10, not IE 11 like I said above. 

- My 2nd question is fixed thanks to the llw.js fix. Did I download an older version of the LocalLayer Widget or is this your fix for this widget?

- For my 1st question, the webmap works in Firefox no problem, no console errors. It works in Chrome, but the console shows some errors which do not seem to impact the webmap performance. Firefox works good, no errors. It does not work in IE 10, the console shows lots of errors. See screenshots of Browser Consoles:

Browser console screenshot from IE 10:

Chrome:

Firefox (no errors):

The primary browser in my organization is IE 11, I am waiting to get HTTPS set up before I test in IE 11. Chrome is widely used as the alternate browser. No one really uses Firefox. 

0 Kudos
TimHayes
Regular Contributor

Here is an update. Just now, I deployed a webmap from WAB DE 2.11 into IE 11. It works! no issues. Still does not work in IE 10, but luckily we no longer use IE 10, we use IE 11 and/or Chrome. We do not use Firefox. 

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

The chrome error will go away as soon as your add the woff and woff2 mime types to your IIS.

Set mime types for web fonts in IIS » Coding Still 

The llw.js I sent you is my mods to the file to fix the errors you were seeing.