Layer List widget causes slow down when zooming

887
8
06-29-2017 02:32 PM
KurtisGagne1
New Contributor II

Has anyone experienced this? I'm using developer edition 2.4 and users have been complaining about 3 to 10 second pauses when zooming.

I tested the map itself by viewing the it in portal, it displays correctly with no pauses at all. Then on a whim I stopped the layer list widget in the app from automatically loading on startup of the web app, this gave a near instantaneous zoom response. Then I opened the layer list widget manually and the pauses in zooming had returned. Additionally, after closing the Layer List the zooming pauses remain as the widget isn't automatically unloaded when closed.

This map does have a moderate amount of layers, however there are no pauses zooming when viewing the map in ArcGIS Portal, or when the layer list widget is disabled in the web app. This is making me suspect a bug where the map is waiting to draw while the layer list is doing something else. Perhaps it's checking weather each layer is visible at that scale??

Does anyone have any ideas as to what I'm doing wrong, suggestions or a work-around that I could try?

Thanks,

-Kurtis

0 Kudos
8 Replies
CynthiaKozma
Occasional Contributor

Kurtis,

Did you find any solution to this??  We are having the same exact problem, and found it related to the Layer List!

-Cindy

0 Kudos
DavidMann1
New Contributor III

Subscribed, any solutions been found?  We have this exact problem as well when the map being consumed has a large amount of layers in it.  Performs fine until Layer List widget has been launched, then zooming becomes painfully slow.  Maps with less data don't have this issue.  I imagined it had something to do with the Layer List needing to parse through each layer for scale dependency anytime the zoom scale changes.

0 Kudos
MichaelMartian
New Contributor II

I contacted ESRI for help with this, and they have logged it as a bug.  There is definitely a correlation between the number of layers and launching the Layer List widget.  There seems to be a limit to the layers you can have before it becomes painfully slow to render.

ErwinSoekianto
Esri Regular Contributor

kurtis.gagne_NewGoldcynthiakYakimaGISdbmann

Do any of you have public WAB app that repro this issue? 

I am interested to see this issue. 

Thanks,

Erwin

0 Kudos
MichaelMartian
New Contributor II

Erwin, we do not have a public facing example. The server that this is hosted on is internal only.

If you have any questions let me know.

Michael Martian, GISP

Director | Yakima County GIS

128 N 2nd St | Yakima, WA 98901

Main: 509.574.2992 | Cell: 509.961.2686

michael.martian@co.yakima.wa.us

http://www.co.yakima.wa.us/gis

0 Kudos
DavidMann1
New Contributor III

No, we do not either.

0 Kudos
AsierJiménez
New Contributor

Hello,

That slow performance is caused because of the _onZoomEnd function of the LayerList widget. That function sets the gray or not gray style in the different layers according to the result of the layerInfo.isInScale() of each layer. In case of having a big amount of layers, if you comment the content of tha function you will not have slow performance anymore (but you will lose the functionality of having different colors depending on the visibility of the layers...).

To be or not to be, that is the cuestion!

RadoslawCylwik
New Contributor III

I'm having the exact same problem as mentioned above and your solution is exactly what I need.  How do I implement it?  Can you give a more detailed description?

0 Kudos