Incorporating web map pop up styles with WAB edit widget popups?

3017
2
Jump to solution
07-20-2015 12:09 PM
TylerBragg2
Occasional Contributor II

I am designing an app through the online WAB, and while I went through style changes to the popups when I created the web map (such as enabling rich text entry boxes and multi-line text boxes so long responses would be easily read), once I put it into WAB and the "Edit" widget is enabled, the pop up reverts to the standard one-line attribute entry, and it shows all the attributes even if I have them turned off in the popup from the web map. NOW, if I open up the app and don't click the edit widget, the web map popups I want are there.

I'm attaching pictures of the popups to better illustrate what I'm wanting. "Capture1.PNG" is the popup style of the web map that I want to incorporate. "Capture2.PNG" is what I get in the WAB edit widget.


Is this an issue being addressed for WAB? Any quick fixes, or is this a scripting issue? I'd really like to incorporate rich text boxes for two of the fields in the edit widget's pop up window when placing a new feature, but if there's no clear fix without a hefty amount of scripting, then I can live with it for the time being. Thanks in advance!

0 Kudos
1 Solution

Accepted Solutions
XiaodongWang
Esri Contributor

Marvin,

Yes, this is a known issue in WAB issue list,

ENH-000085884 When a layer is configured for popups in map viewer, and loaded into Web AppBuilder to be used with the Edit widget, all of the fields are visible when the layer is being edited, not just those configured in the pop up. #2771

Edit widget does not respect the settings of webmap popup, we will fix it in next release. Sorry for any inconvenience caused.

I think there is a workaround can solve this problem temporary, steps as below:

(assume your app name is wabApp)

1, backup your wabApp use saveAs in WAB, avoid damage your app.

01.png

2, go to MyContent, find wabApp, enter to the wabApp item page, click Edit, enter edit item page:

02.png

3, change the 'Purpose' drop box to Configurable:

for now, maybe you cannot see 'Configuration Parameters' text box, this is a bug of online, you have to click 'Save' button and enter this page(edit page) again by click 'Edit' button. and now you will see 'Configuration Parameters' text box.

03_1.png

4, use itemData REST URL to get configuration of your wabApp from browser:

http://arcgisOnline---/sharing/content/items/ed1d7039b4a64dd5a0484ecfc302571f/data

(1,you need to share your app as publish, else you have to use token parameter to access itemData.

  2, please disable any 'JSONFormat' plugin of you browser, such as Json Viewer in chrome)

04.png

5, copy the wabApp's confguration from browser to you text editor, point to the part of editWidget, find the layer, find the field config witch you want using 'Rich Text', for example the field name is 'Emergency Facility ID', and then add "stringFieldOption": "richtext" property to configuration.

05.png

6, copy configuration and paste to the 'Configuration Parameters' text box, click 'Save' button,

06_1.png

7, try to access your app, open edit widget, add a new feature, you will see rich box for 'Emergency Facility ID' attribute:

07.png

View solution in original post

2 Replies
XiaodongWang
Esri Contributor

Marvin,

Yes, this is a known issue in WAB issue list,

ENH-000085884 When a layer is configured for popups in map viewer, and loaded into Web AppBuilder to be used with the Edit widget, all of the fields are visible when the layer is being edited, not just those configured in the pop up. #2771

Edit widget does not respect the settings of webmap popup, we will fix it in next release. Sorry for any inconvenience caused.

I think there is a workaround can solve this problem temporary, steps as below:

(assume your app name is wabApp)

1, backup your wabApp use saveAs in WAB, avoid damage your app.

01.png

2, go to MyContent, find wabApp, enter to the wabApp item page, click Edit, enter edit item page:

02.png

3, change the 'Purpose' drop box to Configurable:

for now, maybe you cannot see 'Configuration Parameters' text box, this is a bug of online, you have to click 'Save' button and enter this page(edit page) again by click 'Edit' button. and now you will see 'Configuration Parameters' text box.

03_1.png

4, use itemData REST URL to get configuration of your wabApp from browser:

http://arcgisOnline---/sharing/content/items/ed1d7039b4a64dd5a0484ecfc302571f/data

(1,you need to share your app as publish, else you have to use token parameter to access itemData.

  2, please disable any 'JSONFormat' plugin of you browser, such as Json Viewer in chrome)

04.png

5, copy the wabApp's confguration from browser to you text editor, point to the part of editWidget, find the layer, find the field config witch you want using 'Rich Text', for example the field name is 'Emergency Facility ID', and then add "stringFieldOption": "richtext" property to configuration.

05.png

6, copy configuration and paste to the 'Configuration Parameters' text box, click 'Save' button,

06_1.png

7, try to access your app, open edit widget, add a new feature, you will see rich box for 'Emergency Facility ID' attribute:

07.png

TylerBragg2
Occasional Contributor II

Thank you Xiadong. I will try the workaround, but I feel better knowing it'll be fixed in the future. I also tried the plain "Editor" app template on a new app and found the popups were the same as the web map in it, so I figured it wasn't too bad of a fix.

0 Kudos