Importing App created in WAB2.8 to 2.9

186
1
08-31-2018 01:04 AM
Nicole_Ueberschär
Esri Regular Contributor

I received an app created in WAB2.8 (developers edition). The last version I had installed was 2.4... I upgraded to 2.9 but struggle now to import the 2.8 app. The direct import as a zip file fails without message. 

I thought of installing 2.8 and upgrade from there but also can't find old installation files anywhere. 

Thanks for any support. 

0 Kudos
1 Reply
RobertScheitlin__GISP
MVP Esteemed Contributor

Nicole,

   When importing an app fails there is a simple workaround you can use. 

  1. Create a new app (note the app# from the apps url).
  2. Unzip app you want to add to a temp location.
  3. copy the contents of the unziped app from step 2.
  4. browse to the app# folder location from step 1 and delete EVERYTHING from that folder.
  5. Paste the copied app.

That's it now you have that app running in that WAB.