I am having issues with AGOL Swipe Map and Default Extent

449
1
04-17-2018 08:06 AM
TobyJacobs2
New Contributor II

I cannot seem to get the Swipe Map to stick with the default extent of the original map (or to change it at all, in fact) when it first shows up. I've tried all of the Extent options, including "Apply to Main Map" and just moving the extent box around. I also tried clearing the cache and that had no effect.

It clearly 'knows' what the default extent should be as it goes there when I click the home button, but it always initially loads zoomed out an extra level. Any ideas?

Here's the story map:

https://prltrust.maps.arcgis.com/apps/StorytellingSwipe/index.html?appid=d4819e62f45c496f9319caef934... 

A possibly related issue is that I've noticed Arc creating a duplicate of the web map that the app is based on every time I save the map. They all have the same name (no "copy"), and if I delete any one of them I lose the story map. I have about 12 duplicate maps currently. Anyone experienced this?

Thanks,

Toby

Tags (2)
1 Reply
AllanSchori
New Contributor

I ran into the same issue. It looks like a bug. The work around is a little annoying/takes some time. What you need to each time you want to adjust the initial extent is delete everything (your swipe map, your map and all the layers) and start again. This time before you re-share the map from the desktop app zoom to your desired extent.