How to Start WAB-developer edition with HTTPS?

596
6
Jump to solution
11-18-2018 03:38 PM
PrashantKirpan
Occasional Contributor

Hi All,

I am trying to run WAB-developer edition 2.10 using HTTPS because my portal is installed on secured environment. After running "startup.bat" from installed location i.e "C:\WebAppBuilderForArcGIS\",I tried to access developer edition using HTTPS but getting below exception. 

Any help would be appreciated.

Regards,

Prashant 

1 Solution

Accepted Solutions
PrashantKirpan
Occasional Contributor

Hi,

I have tired the steps mentioned in above blog but node.js doesn't start after replacing files. So i have followed steps mentioned in below blog. It generates *.pem files using .pfx and some additional configuration is required to make it working.

How To: Use a CA-signed SSL certificate for Web AppBuilder for ArcGIS (Developer Edition) 

Steps :

  1. Repalce *.pem in WAB server folder
  2. Run --> mmc.exe
  3. File --> Add/Remove Snap-in
  4. Certificates --> click Add
  5. Computer Account and finish wizard
  6. Console Root --> Trusted Root Certification Authorities -> Certificate
  7. All Tasks --> Import -> .pfx
  8. Start WAB-Dev 

Regards,

Prashant

View solution in original post

0 Kudos
6 Replies
AnthonyRyanEQL
Occasional Contributor III

Prashant,

I get the same message when I work with WAB dev. I just click the 'Continue to this website (not recommended)' and it works without a problem. It will be interesting to hear what other people have to say

Regards

PrashantKirpan
Occasional Contributor

Hi Anthony,

What portal url are you using? There is no issue if portal is hosted on non secured environment(http).

I tried to run WAB dev with 'Continue to this website (not recommended)'  but failed to register secured portal url and app id.

I have specified portal url and hit continue button. I got below exception on browser.

Regards,

Prashant

0 Kudos
AnthonyRyanEQL
Occasional Contributor III

Prashant,

I'm using WAB dev 2.10 with Portal 10.3.1 with https only configured. It appears to be working for me.

0 Kudos
PrashantKirpan
Occasional Contributor

Hi Anthony,

I tried with chrome and it seems to be working but still question remains, is this recommended way? because as mentioned in help document https should work with wab dev but not working in my case.

And IE-11 continuously redirecting to "specify portal url" page.

Frequently asked questions—Web AppBuilder for ArcGIS (Developer Edition) | ArcGIS for Developers 

"Web AppBuilder uses a self-signed certificate in Node.js to support HTTPS"

Regards,

Prashant

0 Kudos
KenBuja
MVP Honored Contributor

Take a look at this blog on how to replace the self-signed certificate used by WAB DE.

Enable Web AppBuilder for ArcGIS Developer Edition to work with CA signed Certificates 

PrashantKirpan
Occasional Contributor

Hi,

I have tired the steps mentioned in above blog but node.js doesn't start after replacing files. So i have followed steps mentioned in below blog. It generates *.pem files using .pfx and some additional configuration is required to make it working.

How To: Use a CA-signed SSL certificate for Web AppBuilder for ArcGIS (Developer Edition) 

Steps :

  1. Repalce *.pem in WAB server folder
  2. Run --> mmc.exe
  3. File --> Add/Remove Snap-in
  4. Certificates --> click Add
  5. Computer Account and finish wizard
  6. Console Root --> Trusted Root Certification Authorities -> Certificate
  7. All Tasks --> Import -> .pfx
  8. Start WAB-Dev 

Regards,

Prashant

View solution in original post

0 Kudos