Enable WAB Edit Widget on added layers?

1959
4
Jump to solution
05-12-2016 07:24 AM
CharlesBailey3
Occasional Contributor

Does anyone know a way to automatically enable editing through the WAB editor widget on a layer added to a web map, upon which an app template is based? We are using WAB 1.3 developer version and would like users to be able to create their own feature services through AGOL, add to the web map, and then edit these layers in the app. How can we do this without having to go back into builder mode, configure the widget, download, re-deploy etc etc. Thanks! cob

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

Cob,

  Looking at the widgets code it seems that if you do not have any layers configured in the edit widgets json then every time the widget is opened it will look through the map for editable layers and allow editing of them. But if you have certain layers configured then it will only allow editing of those. Disclaimer.. This is just me looking at the workflow of the widgets internals. I don't use a workflow like yours I have not done any testing.

View solution in original post

0 Kudos
4 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Cob,

  Looking at the widgets code it seems that if you do not have any layers configured in the edit widgets json then every time the widget is opened it will look through the map for editable layers and allow editing of them. But if you have certain layers configured then it will only allow editing of those. Disclaimer.. This is just me looking at the workflow of the widgets internals. I don't use a workflow like yours I have not done any testing.

View solution in original post

0 Kudos
CharlesBailey3
Occasional Contributor

Thanks Robert - do you mean that if I configure the widget to enable

editing on none of the map layers, then it will loop through? I did this

through the WAB widget configuration GUI, which did blank out all of the

LayerInfos in the config_Edit.json file. But when opened, the widget

wouldn't allow editing on any of the layers. Is there another way to do

this, or were you talking about something else? Thanks - cob

On Thu, May 12, 2016 at 11:50 AM, Robert Scheitlin, GISP <geonet@esri.com>

0 Kudos
CharlesBailey3
Occasional Contributor

Wait, I have it - deleting the config_Edit file resets it back to the default in the widget. Only had to enable merge/cut etc. in that file and refresh the app... it works! You're a genius, thanks Robert!

0 Kudos
JoseSanchez
Occasional Contributor III

Hi,

Where did you enable merge/cut  after deleting the config_Edit?

Thanks

0 Kudos