Distance and Direction Widget Giving Incorrect Angle?

385
2
Jump to solution
06-05-2020 07:07 AM
MattChomicky1
New Contributor II

Hi,

I am running into an issue with the Distance and Direction widget where the angle returned by the line measurement is not consistent with the angle returned by the Measure tool in Pro, the azimuth/heading measured in Google Earth, and even within the Distance and Direction widget itself when drawing the line interactively (but when not having yet completed the line by clicking).

To demonstrate, here is a screenshot of the measurement between two points in Pro (35°):

Here is a screenshot of the measurement performed in Google Earth (34.7°):

Here is the result displayed by the widget before clicking to finish the line (34.24°):

And here is the result for the exact same line after clicking to finish drawing the line (41.6°):

Any ideas what could be causing this discrepancy, particularly within the widget itself?

Thanks!

0 Kudos
1 Solution

Accepted Solutions
KevinGonzago
Esri Contributor

@MattChomicky1 Thanks for sharing this issue. That has been addressed in the latest release of the widget. Please give it try and let me know if you have any other issues with the widget.

View solution in original post

2 Replies
MattChomicky1
New Contributor II

I should also note that I tried this with a web app that I created using one of the WGS84 basemaps as well, with the same result.

0 Kudos
KevinGonzago
Esri Contributor

@MattChomicky1 Thanks for sharing this issue. That has been addressed in the latest release of the widget. Please give it try and let me know if you have any other issues with the widget.