Basemaps not showing with Beta 3

1758
8
Jump to solution
11-04-2014 06:57 AM
mpboyle
Regular Contributor

I created and downloaded my first app using Beta 3 and none of our basemaps show in the basemap widget.  They all appear when I configure the basemap widget, but if I click on the basemap widget within the app builder or after downloaded, nothing shows.

Has anyone else experienced this?...or have any suggestions what the issue is?

0 Kudos
1 Solution

Accepted Solutions
StanMcShinsky
Regular Contributor

I had the same issue. I went to the config_Basemap.json file and removed the empty tags like {}, (line 75 in your file) and it worked again.

View solution in original post

0 Kudos
8 Replies
mpboyle
Regular Contributor

...below is the code within the config_Basemap.json file...

{

  "basemapGallery": {

    "basemaps": [

      {

        "layers": [

          {

            "id": "baseImagery2012_8036",

            "opacity": 1,

            "visibility": true,

            "url": "http://gis.linncounty.org/arcgis/rest/services/PublicBase/baseImagery2012/MapServer"

          }

        ],

        "title": "2012 Imagery Base",

        "thumbnailUrl": "http://linncounty-gis.maps.arcgis.com/sharing/rest/content/items/11083efc958c43fd90980dc2869b05b7/in...",

        "spatialReference": {

          "wkid": 102675,

          "latestWkid": 3417

        }

      },

      {

        "layers": [

          {

            "id": "baseImagery2012_3805",

            "opacity": 1,

            "visibility": true,

            "url": "http://gis.linncounty.org/arcgis/rest/services/PublicBase/baseImagery2012/MapServer"

          },

          {

            "id": "baseImageryLabels_8314",

            "isReference": true,

            "opacity": 1,

            "visibility": true,

            "url": "http://gis.linncounty.org/arcgis/rest/services/PublicBase/baseImageryLabels/MapServer"

          }

        ],

        "title": "2012 Imagery with Labels Base",

        "thumbnailUrl": "http://linncounty-gis.maps.arcgis.com/sharing/rest/content/items/eafdcd8eb4e74e489cdc97b76304d3df/in...",

        "spatialReference": {

          "wkid": 102675,

          "latestWkid": 3417

        }

      },

      {

        "layers": [

          {

            "id": "baseMapLinnCountyCadastral_8931",

            "opacity": 1,

            "visibility": true,

            "url": "http://gis.linncounty.org/arcgis/rest/services/PublicBase/baseMapLinnCountyCadastral/MapServer"

          }

        ],

        "title": "Cadastral Base",

        "thumbnailUrl": "http://linncounty-gis.maps.arcgis.com/sharing/rest/content/items/2cab862785c849a0bd3620e5639ab135/in...",

        "spatialReference": {

          "wkid": 102675,

          "latestWkid": 3417

        }

      },

      {

        "layers": [

          {

            "id": "baseMapLinnCountyGray_9319",

            "opacity": 1,

            "visibility": true,

            "url": "http://gis.linncounty.org/arcgis/rest/services/PublicBase/baseMapLinnCountyGray/MapServer"

          }

        ],

        "title": "Grayscale Base",

        "thumbnailUrl": "http://linncounty-gis.maps.arcgis.com/sharing/rest/content/items/44b0d0424b3e447a8ddbf8a8eafee595/in...",

        "spatialReference": {

          "wkid": 102675,

          "latestWkid": 3417

        }

      },

      {},

      {},

      {},

      {},

      {},

      {

        "layers": [

          {

            "id": "baseMapLinnCounty_3680",

            "opacity": 1,

            "visibility": true,

            "url": "http://gis.linncounty.org/arcgis/rest/services/PublicBase/baseMapLinnCounty/MapServer"

          }

        ],

        "title": "Standard Base",

        "thumbnailUrl": "http://linncounty-gis.maps.arcgis.com/sharing/rest/content/items/300a7d7706724daa8e5f233cbc939791/in...",

        "spatialReference": {

          "wkid": 102675,

          "latestWkid": 3417

        }

      },

      {},

      {},

      {},

      {

        "layers": [

          {

            "id": "baseMapLinnCountyTopo_2671",

            "opacity": 1,

            "visibility": true,

            "url": "http://gis.linncounty.org/arcgis/rest/services/PublicBase/baseMapLinnCountyTopo/MapServer"

          }

        ],

        "title": "Topographic Base",

        "thumbnailUrl": "http://linncounty-gis.maps.arcgis.com/sharing/rest/content/items/e993542284d949cdba83687a25a0a205/in...",

        "spatialReference": {

          "wkid": 102675,

          "latestWkid": 3417

        }

      }

    ]

  }

}

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Matthew,

   In Beta 3 the ability to specify baseamps and operational layers in the main config.json has been partially removed and broken. I don't know if there are any concrete plans to fix this or not in the final release.

0 Kudos
mpboyle
Regular Contributor

Is there a way to get our basemaps to show in the basemap widget...?

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Matthew,

   I can get the basemap gallery widget to use the basemaps from my server as long as they have the same spatial ref as the webmap that I am using

0 Kudos
mpboyle
Regular Contributor

Our basemaps are all in State Plane, as are the services overlaid on our basemaps.  Is there something in the code where the WKIDs are off...?

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Matthew but is your WebMap that you begin the whole Web AppBuilder application preparation (when on the map tab), does that web map use state plane? I have been completely unsucessful in using a state plane web map and then trying to use state plane basemaps in the basemap gallery widget (at least in  Beta 3).

0 Kudos
StanMcShinsky
Regular Contributor

I had the same issue. I went to the config_Basemap.json file and removed the empty tags like {}, (line 75 in your file) and it worked again.

0 Kudos
mpboyle
Regular Contributor

Stan McShinsky‌ - that did it, thanks for the tip!

0 Kudos