After AGOL updates, Web App Builder Geocoding Functionality broken.

4266
23
07-14-2015 06:18 AM
PaigeLester1
New Contributor III

My organization uses our own Composite Address Locator Geocoding Service that has been published to our own ArcGIS Server. Prior to ESRI's July updates to ArcGIS Online, with a Web App Builder Web App, when a street address is typed into the Search text box and the user pauses, the app returns a list of candidates from our Geocoding Service. After this 2015 July update, this behavior has changed without warning. After entering the address, one now has to press the enter key to return the list of candidates. The best candidates, e.g. the candidates with a match score of 100, are highlighted or bolded in black, but the highlighted best results are not selectable.

0 Kudos
23 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Paige,

   The geocoder widget has been switched to the JS APIs Search widget in the latest online WAB version. The functionality has changed because of this. The Search widget has a lot more capabilities and confiurability, but also comes with a Bug in the current JS API release where the bolded portion of the result being the only portion that has the link functionality.

0 Kudos
PaigeLester1
New Contributor III

Robert,

The issue I am experiencing is that I am unable to select the first bolded item in the list at all. The best candidate is not selectable (the only result that does not have link functionality). Perhaps a programming mistake that has been overlooked.

0 Kudos
BjornSvensson
Esri Regular Contributor

Robert, the 3.13 bug about not being to click the bold part of the search result has been fixed for 3.14 - and in the new online WAB  I think Paige was having a different issue.

Paige, could you try again today and see if you're still having the problem?

WilliamRice
Occasional Contributor II

Bjorn,

The screen snapshot below shows the lists of candidates returned from the WAB Search Widget with our organization's ArcGIS Server Geocoding Service.  After the July 2015 AGOL update, we can no longer select the first and best candidate in the list.

WAB_Search_Error.png

PaigeLester1
New Contributor III

Bjorn,

Yes, the issue still persists. Please see the issue posted by William Rice - this is the same problem.

Thanks for taking a look!

0 Kudos
WilliamRice
Occasional Contributor II

This issue with the Search Widget with a Web App Builder app when using an organization's own ArcGIS Server Geocoding Service has been submitted as a bug with the Web App Builder.  See BUG-000089016:Address search suggestions are not returned as expected in Web AppBuilder while using a custom Geocoding service

Jianxia
Esri Regular Contributor

William,

To trouble shoot, could you help do the same search in map viewer and see if the problem happens?

Thanks,

Jianxia

0 Kudos
WilliamRice
Occasional Contributor II

Hello Jianxia,

Viewing the source web map for our Web App Builder app in the ArcGIS Online Map Viewer, when I enter the address "1800 27TH ST" and press the Enter key on the keyboard, a list of candidates is not returned.  Instead the Search widget selects the best candidate and then zooms to that location on the map.  With the Map Viewer, the best candidate is being selected and used by the Search Widget.

In contrast, with the Web App, the list of candidates for an address is returned.  But, after the July 2015 AGOL update, I can no longer select the first address from the returned list of candidates.

Will Rice

0 Kudos
Jianxia
Esri Regular Contributor

Thank you Will.

I ran a quick testing and found if i click the blank area of the best candidate, it is selected and zoomed to the feature. Could you give it a try?

0 Kudos