Unable to Submit Survey while using Cell phone connection

281
4
Jump to solution
11-08-2021 10:43 AM
MarthaRodgers
New Contributor III

Hello all, can someone please clarify this question?

Are we able to submit a Survey while NOT on Wifi but YES with a cell phone signal/connection?

Every time I hit submit when I'm out and about not using Wifi, it says I am "Offline" and must save in the Outbox.

IMG_5165.PNG

 

But my cell signal is just fine.

Is there a setting I'm missing somewhere?   It seems like this used to work for me....


Thank you!

Martha

0 Kudos
2 Solutions

Accepted Solutions
MichaelMorris1
New Contributor

Thank you @ABishop , since you commented that it might be something on my side I was able to do some testing, and it looks like the default of "using Cellular Data" is turned OFF for Survey123.  

On my iPhone --> Settings --> Cellular --> scroll down to "Survey123"   (see attached)

Looks like all other apps have that automatically turned on.  Perhaps I changed a setting a while ago and forgot, or perhaps this is the default now, either way, it might be helpful for others who come across this same issue.

Thanks!

Martha

 

 

 

View solution in original post

Philip-Wilson
Esri Notable Contributor

Hi @MarthaRodgers,

The cellular data option for the Survey123 field app on all platforms should be on by default when the app is installed, and provided you have a valid data subscription with your cellular service, the app will be able to connect and download and submit surveys using that service.

The only way to turn this option off is manually via the OS settings. Glad you found this option was off and got it working again.

Regards,

Phil.

View solution in original post

4 Replies
ABishop
Regular Contributor III

Hello @MarthaRodgers 

I have seen a couple of posts with Survey123 and issues with connectivity.  Some of the issues relate to the version of the app and also the mobile platform being used to access and submit the survey.  I suggest you do a bit of testing with different versions and mobile platforms to see if these could be an issue.  Also do a search for bugs related to Survey123 here: https://support.esri.com/en/Search-Results#search?q=Survey123&content-type=Bugs 

Amanda Bishop, GISP
0 Kudos
MichaelMorris1
New Contributor

Thank you @ABishop , since you commented that it might be something on my side I was able to do some testing, and it looks like the default of "using Cellular Data" is turned OFF for Survey123.  

On my iPhone --> Settings --> Cellular --> scroll down to "Survey123"   (see attached)

Looks like all other apps have that automatically turned on.  Perhaps I changed a setting a while ago and forgot, or perhaps this is the default now, either way, it might be helpful for others who come across this same issue.

Thanks!

Martha

 

 

 

MarthaRodgers
New Contributor III

@MichaelMorris1 @ABishop  Not sure what happened, there, but this message was supposed to come from my account.   (Martha)

Sorry about that!

-Martha

 

0 Kudos
Philip-Wilson
Esri Notable Contributor

Hi @MarthaRodgers,

The cellular data option for the Survey123 field app on all platforms should be on by default when the app is installed, and provided you have a valid data subscription with your cellular service, the app will be able to connect and download and submit surveys using that service.

The only way to turn this option off is manually via the OS settings. Glad you found this option was off and got it working again.

Regards,

Phil.