TypeError: Function expected

405
7
05-28-2019 05:53 AM
Highlighted
New Contributor III

My colleague is producing a survey in Survey123 through the web designer UI.

During design, when she test Example, she get this error: "TypeError: Function expected"

I also have another colleague with same problem.

Where can I check to find this error - there is no hint to which function is missing.

Karl

Reply
0 Kudos
7 Replies
Highlighted
Esri Esteemed Contributor

Hi Karl,

At what point is the error displayed?  What specific task in creating a survey was being done?

Reply
0 Kudos
Highlighted
New Contributor III

We tested on some other computers and users. Some had this problem, some didn't. I have the idea (from Google search also) it could have something to do with javascript rules in the used browsers / internet settings. For the specific user it was in Edge and IE provided by their organization. What can be done? The survey can be used by for unnamed public users whom I can't support much - and they are probably not interested in spending much time on problems. I would think it is something to be changed in the javascript code to be effective.

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Hi Karl,

Could you share the form or provide a link to it?  There are a few areas where IE/Edge incompatibility is an issue.

Reply
0 Kudos
Highlighted
New Contributor III

Hi James,

According to my colleague it should be this one:

https://survey123.arcgis.com/share/043cb49dc79f43febb0a3781977dbd8b

Karl Brix Zinglersen

Reply
0 Kudos
Highlighted
Occasional Contributor

Hi.  Does anyone know how to resolve this?  We've had several people report the error on a survey we released yesterday.  Others are not receiving the error.  


Thanks.

Reply
0 Kudos
Highlighted
New Contributor III

To my knowledge, we didn't receive an answer or find a solution to the problem.

James Tedrick‌ can you assist?

Karl

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Hi Mary, Karl Brix Zinglersen‌,

It is somewhat difficult to debug this without a reliable reproduction capability - if you have an environment (computer/browser/network) that can reliably reproduce this issue, it would be best to open a ticket with Esri support.

Reply
0 Kudos