Survey123 XLX Error

876
7
08-19-2020 02:01 AM
AliAwad
New Contributor

when i want to create a new surbey123 form using Survey123 connect (Advanced templates), i have an error : ( Microsoft excel: We found a problem with some content in 'Form3.xlx.'. Do you want us to try to recover as much as we can? if you trust the source of this workbook, click yes.).

Note: i tried to create a standard templates and i haven't any error!

Tags (1)
0 Kudos
7 Replies
Philip-Wilson
Esri Notable Contributor

Hi Ali,

What version of Survey123 Connect are you using, and also what version of Microsoft Excel?

I just tested creating a survey from Advanced template with 3.10 Connect on Windows 10 with latest version of Excel Office 365, and it was created successfully without any errors and the workbook opened ok.

Regards,

Phil.

0 Kudos
AliAwad
New Contributor

Hi Philip,

I'm using Survey123 3.10, and Microsoft office 2016.

I think the problem is in the excel not in the survey, But no one was able to support a solution to this problem, and the strange thing is that Excel works normally except when using Advanced Templates.

Best regards,

Ali.

0 Kudos
Philip-Wilson
Esri Notable Contributor

Hi Ali,

Is this a new issue with 3.10, or did it occur with 3.9 Connect also? The templates have been updated for 3.10 however the Advanced and Standard are very similar so would expect the same issue with both.

Have you tried on another computer with Excel, or does it only happen on your computer?

Regards,

Phil.

0 Kudos
Philip-Wilson
Esri Notable Contributor

Hi Ali,

We have updated the Advanced Template item in AGO (within the past hour) and run a repair on the xlsx file, hopefully this will address the problem.

Can you please try again to create a new survey from Advanced Template, and let us know the outcome?

Regards,

Phil.

0 Kudos
AndrewE
New Contributor III

I am getting the same error but only when I try to create a survey from an existing feature service. 

0 Kudos
Philip-Wilson
Esri Notable Contributor

Hi Andrew,

This issue has been fixed for 3.11 as the template used for an existing feature service is built into Connect, so we can not just update the Online item. The fix will be available in the Connect 3.11 RC builds on Early Adopter Community in the next few days.

In the meantime, what you can do is take the attached internal XLSFormTemplate and copy it to the following location (on Windows):

C:\Users\{username}\AppData\Local\Temp\

This is where the internal template gets extracted to when you create a survey from an existing feature service. So if you update the template first in this location, then create the survey, it will use the new one.

Regards,

Phil.

0 Kudos
AndrewE
New Contributor III

Thanks Philip, 

That worked perfectly and I'll keep an eye out for 3.11 update.