Survey123 data transferring to client

86
2
04-29-2019 07:14 PM
Highlighted
Occasional Contributor II

Hi,

I need help regarding how to deliver the data collected in Survey123 to the client for future updation.

I am working on a project where I am designing a Survey to collect data for a client. The collected data then will be handed over to a client and have to regenerate this Survey for them. They will be using this Survey to update an existing database or create a new record in future.

For testing my workflow, I have created a copy of Hosted feature service and recreated a survey using it. In the new survey, I can view an existing record in Inbox and update it, also collect a new record. The only issue I am facing is to recreate a report for an existing record (updated) with photos. I can see the photos in the feature service but can't get it printed on a template

So my questions are

1) Is this a correct workaround?

2) is there any way I can get these photos printed on a template? 

Any help would be highly appreciated.

Thanks,

Anu

Tags (3)
Reply
0 Kudos
2 Replies
Highlighted
Esri Frequent Contributor

Hi Anu Sawant‌  Let me describe first why you cannot see the photos in your reports, and then offer a potential solution.

Photos included in your survey are stored in ArcGIS as attachments. ArcGIS does not have a built-in mechanism to differentiate attachment types. For example, if your survey has a question for a signature and a separate for a photo, both images will be stored as attachments, but ArcGIS cannot tell which one is which. Because of this, it would not be possible for you to define a report template where the signature is placed at the end of the report, and the photo at the beginning.

To solve the above problem, Survey123 for ArcGIS automatically tags the attachments with the name of the corresponding survey question. For example, an image representing a signature would be tagged with 'signature' and the image  corresponding to a photo, will be tagged with 'photo'.  Survey123 tools like our reporting tools and Survey123 website understand and use these tags, but other tools in ArcGIS unfortunately ignore these tags.

During the process of exporting and importing your data, all these tags were lost. Without them, the Survey123 report tools do not known anymore where to put the images in the report.

I have included as an attachment an ArcGIS Pro tool that you can use to restore tags. To use this tool:

  1. Unzip the contents of the attached file.
  2. Add the feature layer of your survey into ArcGIS Pro.
  3. Use the ArcGIS Pro catalog pane to navigate to the location were you unzipped the contents of the file
  4. Run the tool, setting your survey feature layer as an input and specify the tag you want to assign to the attachments. The tags you set should match the name of the questions in your form.  If you have multiple images in your survey, you can use the optional search parameter. The search uses the filenames of your images.

I suggest you experiment with a backup copy of your data first so you can familiarize yourself with how this tool operates. The tool, of course, assumes that your feature layer contains attachments.  I have successfully used this tool in a couple of occasions to recover data and it has worked OK for me. Having said this, the tool has not gone through formal testing, so it is an experimental tool at this moment. Give it a go and see if you can get your data back.  Hope this helps.

Highlighted
Occasional Contributor II

Hi Ismael,

Thanks for the solution. Can I use this tool if my photos are in the related table?

e.g. I am collecting building information, location (feature Layer) and my related table will be showing details information about each floor in that building and photos attached to it.

So when I will be choosing an input in the tool you have provided am I going to choose related table or feature service?

Thanks,

Anu

Reply
0 Kudos