Survey123 Collaborate Tab Error

154
3
10-05-2018 09:26 AM
Highlighted
New Contributor III

Hello,

I am trying to allow users to view the data they submitted using the Survey123  Data tab, however, in the Collaborate tab  I get the error below when trying to change the Viewer settings to the same as the Submitter settings.  Submitter settings will save successfully, but Viewer page settings will not.

I have deleted the _Stakeholder layer from my ArcGIS  folder and then tried to update the settings, but get I this same error.  I have also tried moving my feature layer that I am referencing to the same folder as the survey.  I have checked the sharing on everything and just can't figure out what is causing this error.

Any help would be appreciated. I have included my .xls form for reference.  This is a feature service published on our own GIS server.  I used Survey123 Connect to create this survey.

Thanks!

Josh

Reply
0 Kudos
3 Replies
Highlighted
Occasional Contributor II

Hi Joshua,

There looks to be a defect that is similar to the error you are receiving. 

BUG-000115443 : When the Read-Only property is set to Yes in a Survey123 form on a select_one or select_multiple question, the Survey123 Web App throws an error: TypeError: Cannot read property 'split' of undefined

Are there any read only select one or select multiple questions in your survey?

Best,

Marisa

Reply
0 Kudos
Highlighted
New Contributor III

I don't have any read only fields in my survey form.  Thanks for replying!

Reply
0 Kudos
Highlighted
MVP Regular Contributor

Any updates on BUG-000115443?

Reply
0 Kudos