Survey123 3.0.132 update problems

243
2
Jump to solution
07-11-2018 06:18 AM
Highlighted
New Contributor II

We’ve been using survey123 for 3 years now with no major problem till now. But currently the surveyors are unable to send the data after the last app update “survey123 3.0.132”.

The forms are published using survey123 connect 1.4.30.

I already tried to use Fix database and even re-downloading the surveys, but it didn’t solve the problem.

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Esri Frequent Contributor

Hi Mira,

What mobile devices are you using? As mentioned by Vikram, the latest version of the app required globalids to be enabled, as well as other changes for minimum supported version in Portal, iOS and Android.

You can read more information about 3.0 here: https://community.esri.com/groups/survey123/blog/2018/07/06/bull-release-30 

And to recover your surveys from the devices that can not send, you can find more information here: Troubleshoot—Survey123 for ArcGIS | ArcGIS 

Regards,

Phil.

View solution in original post

2 Replies
Highlighted
Occasional Contributor

Make sure you have the sync option enabled for hosted feature service . If it is using Federated Feature Service make sure the feature class is archive enabled and add global ID 

This is a requirement with latest survey123 update (3.0). If you are using the desktop app with older version you should be fine.

Highlighted
Esri Frequent Contributor

Hi Mira,

What mobile devices are you using? As mentioned by Vikram, the latest version of the app required globalids to be enabled, as well as other changes for minimum supported version in Portal, iOS and Android.

You can read more information about 3.0 here: https://community.esri.com/groups/survey123/blog/2018/07/06/bull-release-30 

And to recover your surveys from the devices that can not send, you can find more information here: Troubleshoot—Survey123 for ArcGIS | ArcGIS 

Regards,

Phil.

View solution in original post