Single Sign on Issues

850
7
02-17-2021 01:46 AM
MorganCrumlish
New Contributor II

Hi,

Single sign on is not working  me.

When one of my users  signs in on Survey123 and signs back out it reverts to the last person to have signed in and doesnt just reset. 

Anyone else have a similar issue ?

Tags (3)
7 Replies
Philip-Wilson
Esri Notable Contributor

Hi @MorganCrumlish,

Can you please confirm what version of Survey123 field app you are using (check the Settings->About screen). And also please confirm on what device and OS version?

Regards,

Phil.

0 Kudos
MorganCrumlish
New Contributor II

Hi Philip,

Thanks for the quick response, unfortunately my guys aren't quite as quick, i will get back to you asap when they answer me. 

MorganCrumlish
New Contributor II

Versions of iOS & Survey123 below:

Survey 123: 3.11.164

iPad –iOS 14.0.1

0 Kudos
Philip-Wilson
Esri Notable Contributor

Hi @MorganCrumlish,

Thanks for the additional information. I assume you are using Enterprise with IWA SSO authentication.

If so, this is a known issue when using non-Windows devices, such as Android and iOS devices. The sign in session gets cached in the login webview, so once the user signs out, and you try to sign back in, the cached credentials are used. We are working on fixing this issue in the internal browser and will have an update for you once we make progress.

Regards,

Phil.

0 Kudos
MeleKoneya1
New Contributor III

Glad I found this.   We have Fire crews using iPads which don't use our O365 logins used throughout the City, but our AGOL site is using O365 and we have seen this issue where the previous user is still logged in.    I will be curious to hear the resolution and any possible work arounds for now.   

AzinSharaf
Occasional Contributor II

@Philip-Wilson  

Hi Philip, Do you have any update on this case?

0 Kudos
Philip-Wilson
Esri Notable Contributor

Hi @AzinSharaf,

There is currently no update on this issue and it is unlikely to be resolved for the upcoming release, and requires further changes in the underlying AppStudio framework version.

Regards,

Phil.