Reverse Geocoding in Survey123 Webform not working

859
5
01-29-2019 03:07 PM
Highlighted
New Contributor III

I was wondering if reverse geocoding using the pull down function published out of Survey123 Connects works in the the Survey123 web form. I have tested this in the Survey123 field app for desktop and it works but it does not seem to be pulling the location info from our geocoding service through the webform. 

Another issue is the default value for a select_one type question is not working in the webform either when it is working fine in the Survey123 field app for desktop.

Any ideas? Let me know if I need to provide additional information.

Survey is public and can be accessed here: https://arcg.is/0LDLSe  but the geocoder used is not accessible if not signed into our organisation but it is a public geocoder so should still populate the address in the database even if you are not able to select it in the map address search.

Thank you,

Simon

Reply
0 Kudos
5 Replies
Highlighted
Esri Esteemed Contributor

Hi Simon,

I can see an issue in the reverse geocode request - it is sending a token, causing a security error.

Could I also ask that you confirm the reverse geocoding task works with a lat,long coordinate?  When trying to work with the geocode (for example, Reverse Geocode: (LINZ_Street_Address_Locator_Test) ), I'm not getting a result.

Reply
0 Kudos
Highlighted
New Contributor III

Hi James,

Thank you for your reply. I can’t seem to get the correct syntax for populating the geocoded address from a lat long coordinate using the rest end geocoding service that we’ve created from LINZ data https://gistest.boprc.govt.nz/server/rest/services/LINZ_Street_Address_Locator_Test/GeocodeServer/reverseGeocode

Here is the feature service (public) that is used to store the records from the survey. https://services1.arcgis.com/TWsoAGve3wb3oFHK/arcgis/rest/services/service_6d293b9993ab4a708a05940c8f52c079/FeatureServer

I have repeated the same test using the same address. 6 Mair Street, Matatā. See Object ID 51 and 52. I have entered similar data both in the webapp and in the desktop field app of survey123 and the results are different.

The X and Y lat long fields are populated everytime in both apps using the esri geocoder with simply the pulldata function but the reversegeocode.location and reversegeocode.adress.Match_addy only seem to be working when being run out of the desktop app (tested using both ESRI and our test LINZ geocoder).

Is it possible that this could be a bug?

hidden

PWaterTake_LINZRevGeocodeAddy

Reverse geocoded address at primary water take location

pulldata("@geopoint",$,"reversegeocode.address.Match_addr", "https://gistest.boprc.govt.nz/server/rest/services/LINZ_Street_Address_Locator_Test/GeocodeServer") hidden PWaterTake_LINZRevGeocodeX Reverse geocoded location at LINZ address point X Coordinate pulldata("@geopoint",$, "reversegeocode.location.x", "https://gistest.boprc.govt.nz/server/rest/services/LINZ_Street_Address_Locator_Test/GeocodeServer")

hidden

PWaterTake_LINZRevGeocodeY

Reverse geocoded location at LINZ address point Y Coordinate

pulldata("@geopoint",$, "reversegeocode.location.y", "https://gistest.boprc.govt.nz/server/rest/services/LINZ_Street_Address_Locator_Test/GeocodeServer") hidden ESRIGeocodedAddressPrimaryTake ESRIGeocodedAddressPrimaryTake pulldata("@geopoint",$,"reversegeocode.address.Match_addr")

hidden

LatitudePrimaryTake

Latitude

pulldata("@geopoint", $,"y") hidden LongitudePrimaryTake Longitude pulldata("@geopoint", $,"x")

Cheers,

Simon Allard

GIS Analyst

Bay of Plenty Regional Council Toi Moana

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Hi Simon,

The issue with regard to the token is a bug and we will look to fix it.

Highlighted
Esri Contributor

Do we have a BUG number logged for this?

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Hi Éric,

There is not an Esri Support BUG-# number associated with this issue.  If you want to work with Support to have one filed, please let me know.

Reply
0 Kudos