Select to view content in your preferred language

Pull Data gives wrong address Survey123 connect

427
1
09-04-2023 08:10 AM
TalHill
New Contributor

Hi,

I  have a problem  in survey123 when i try to retrive an address from geopoint question.
I have a geopoint question type which lets the use to select location. the location is often selected using the search bar at the top. After the user selects the desired location i pull the address of the location using "pulldata" function into a seprate field. Fro some reasont the address o get is difreent then the adress that was searched for and selected for the geopoint.

This is the pulldata function i use:  pulldata("@geopoint",${location},"reversegeocode.address.Address")

I am located in israel and i use the ArcGis world geocoding service for my organization. 
Do you have an idea why this is happened?

 

 

0 Kudos
1 Reply
TalHill
New Contributor

Update:
Ok i found that the reverse geopoint can bring several kind of outputs. It can be an address but also can be POI or similar. The initial problem was that i got back POI in some cases and not the address. To filter on adrress you have to specify it using the featureTypes parameter in the pull data function.
like this:
pulldata("@geopoint",${location},"reversegeocode","https://geocode.arcgis.com/arcgis/rest/services/World/GeocodeServer","featureTypes=StreetAddress")
 mor information on this here and here

BUT i still get diffrent addresses then the on i ninserted in the fsearch box. very close ones but still diffrent.
For example when i write "Hasan Shukri 5" (only in hebrew) i get back the adress of Hasan Shukri 7.
Cant understand why.


@TalHill wrote:

Hi,

I  have a problem  in survey123 when i try to retrive an address from geopoint question.
I have a geopoint question type which lets the use to select location. the location is often selected using the search bar at the top. After the user selects the desired location i pull the address of the location using "pulldata" function into a seprate field. Fro some reasont the address o get is difreent then the adress that was searched for and selected for the geopoint.

This is the pulldata function i use:  pulldata("@geopoint",${location},"reversegeocode.address.Address")

I am located in israel and i use the ArcGis world geocoding service for my organization. 
Do you have an idea why this is happened?

 

 



@TalHill wrote:

Hi,

I  have a problem  in survey123 when i try to retrive an address from geopoint question.
I have a geopoint question type which lets the use to select location. the location is often selected using the search bar at the top. After the user selects the desired location i pull the address of the location using "pulldata" function into a seprate field. Fro some reasont the address o get is difreent then the adress that was searched for and selected for the geopoint.

This is the pulldata function i use:  pulldata("@geopoint",${location},"reversegeocode.address.Address")

I am located in israel and i use the ArcGis world geocoding service for my organization. 
Do you have an idea why this is happened?

0 Kudos