Select to view content in your preferred language

Publishing Survey using fields that are Non Editable

651
3
Jump to solution
08-18-2023 11:52 AM
LorindaGilbert
Occasional Contributor II

Hi All,

I've got a S123 Survey that is set up to pull existing data that has Attribute Rules associated with it in the SDE.  I've already set up the Pro Project and the Web App for editing in that format.  However, the client prefers to have a form to fill in without using a map (it's the way it's been done since the client has been here).  So, my AR has calculations that are WAY too complex for the S123 form, and the result has to be set to non-editable as the calcs are set by council and the state.

Using Connect 3.17 and have the form pulling the data as it should.  Tried to publish and it gives an error about custom feature service submission url is not compatible and that a field is not editable.  I' attempting to publish to our Enterprise Portal at 10.9.1. 

LorindaGilbert_0-1692384251721.png

If it has an issue with one field not being editable then it seems to me that it would also have an issue with the fields for editor tracking - which will be turned on - that are non-editable as well.

Anyone have any suggestions?  And not make the field editable, can't do that.

Thanks,

Lorinda

0 Kudos
1 Solution

Accepted Solutions
RobertAnderson3
MVP Regular Contributor

In the Survey123 XLS you could try adding 'null' to the bind::esri::type field, it allows you to have the field shown in your form, but it doesn't submit it to the layer (or create the field if you don't need it).

I just did this for objectID because I want it to be able to be seen in my instance_name in the Inbox.

View solution in original post

3 Replies
RobertAnderson3
MVP Regular Contributor

In the Survey123 XLS you could try adding 'null' to the bind::esri::type field, it allows you to have the field shown in your form, but it doesn't submit it to the layer (or create the field if you don't need it).

I just did this for objectID because I want it to be able to be seen in my instance_name in the Inbox.

LorindaGilbert
Occasional Contributor II

Hi Robert,

That worked great for several of the fields in my survey that I need them in there to gather data, such as x, y and setting my urls for the layers.  Thanks a bunch for that tip!  Now it has another issue that I will reply to my original post with.

LorindaGilbert
Occasional Contributor II

Actually the other issue was solved by putting the fieldtype as null as well.  Now to see if the form works as published for editing existing data and for add new!