Multi geometry issue

264
7
Jump to solution
05-12-2020 05:19 AM
SMauri
by
Occasional Contributor III

Hi,

I create a new survey with advanced form and insert two geometry

  • line - main geometry
  • point - secondary geometry

Point is only used to take position from GPS and use reverse geocoding with pulldata function for insert information in text field. And for this question esri:filedType is set to null

So in preview panel you can see that Survey123 will create a Polyline feature layer as you expect.

But...because there is always a but...in my complex scenario, the geopoint question comes first.

Well, whe you invert position...

...you no longer have a feature layer but a table.

Is it a known limitation?

Thank you for your attention

Cheers

Stefano

0 Kudos
1 Solution

Accepted Solutions
Shwu-jingJeng
Esri Regular Contributor

Hi Stefano,

This is a valid issue in the production build of Survey123.

I encourage you to submit this issue as a bug via Esri Support. Our Support team will assign an official bug number for your records. This number can be used to search for and subscribe to the bug on the Esri Support site. If the issue is reported by other customers it will be attached to the same bug report, which helps us assess the impact of the issue and prioritize it accordingly.

View solution in original post

7 Replies
Shwu-jingJeng
Esri Regular Contributor

Hi Stefano,

This is a valid issue in the production build of Survey123.

I encourage you to submit this issue as a bug via Esri Support. Our Support team will assign an official bug number for your records. This number can be used to search for and subscribe to the bug on the Esri Support site. If the issue is reported by other customers it will be attached to the same bug report, which helps us assess the impact of the issue and prioritize it accordingly.

View solution in original post

SMauri
by
Occasional Contributor III

Hi,

do you want to hear a fun fact? Someone from Official Esri Support has replied to me this:

"Unfortunately, I was unable to reproduce the issue at my end with the latest version of the application as well".

Unbelievable, isn't it?

Cheers

Stefano

0 Kudos
Shwu-jingJeng
Esri Regular Contributor

Hi Stefano,

This issue still exists in the 3.9 production and the latest 3.10 beta build of Connect though. Could you send the attached sample XLSForm to Tech Support as it demos the issues?

0 Kudos
SMauri
by
Occasional Contributor III

Sure I can, thank you!

Cheers

Stefano

0 Kudos
SMauri
by
Occasional Contributor III

Update from Official Support from Esri

Motivation: This is by design - the user has explicitly declared that they do not want geometry stored with the survey.

What??? It's not by design...because geopoint question it's not main geometry!

I'm afraid official support doesn't have very clear ideas about how Survey123 works. And they didn't take five minutes to read this report.

Shwu-jing Jeng‌, what else can I do?

Cheers

Stefano

0 Kudos
Shwu-jingJeng
Esri Regular Contributor

Hi Stefano,

It seems like Tech Support attached a wrong existing salesforce issue with your case. The salesforce issue Tech support attached is for one and the only geomeotry field which is set to null. But in your case, your have multiple geometry fields and the order does matter here. We do have an internal issue logged here, however, the priority is low at this point. What you can do is contact the Tech support and have them create a new salesforce issue and emphasize the ORDER of the geometry field for this issue. If they reject, please provide them my name and have them contact me if they have question to log a new salesforce issue for you. Once the new issue is created, I will link to the existing internal issue so that we can track the priority of this issue. You could also track the status of this issue.

Thanks,

0 Kudos
SMauri
by
Occasional Contributor III
What you can do is contact the Tech support and have them create a new salesforce issue and emphasize the ORDER of the geometry field for this issue. If they reject, please provide them my name and have them contact me if they have question to log a new salesforce issue for you. Once the new issue is created, I will link to the existing internal issue so that we can track the priority of this issue

At this point, I spent a bit more time than I wanted to report the issue.

We do have an internal issue logged here, however, the priority is low at this point.

It is enough for me to have reported the problem.

Thanks for your support.

Cheers

Stefano

0 Kudos