Moving Data from one Survey to Another

973
7
12-07-2017 11:55 AM
Highlighted
Occasional Contributor III

I set up a test survey to try out Survey123 by itself and in conjunction with Workforce. During the test phase, I received several good suggestions for the Survey questions and created a new survey to incorporate them. Now, I have a working final version Survey with good data and a few (68) good survey points in the test data.

What is the best way to move the good data in the test survey version to the final survey version?

The fields aren't exactly the same, so a straight-up copy/paste isn't going to work. (Can I even do that with hosted feature layers in AGOL?)

I can re-create the surveys in the new form. They aren't long surveys, but it will still take an hour or so. And then my survey point on the map will be in the wrong location. But, I suppose I could manually move the points to the proper locations...

Any other possibilities I haven't thought of? Which method would be the safest and easiest?

Reply
0 Kudos
7 Replies
Highlighted
Esri Esteemed Contributor

Hi April,

You're in luck!  ArcGIS Online's update last night introduced support for appending data - you can download the current data as GDB and then append it to your new survey layer.  See Manage hosted feature layers—ArcGIS Online Help | ArcGIS  for more information.

Highlighted
Occasional Contributor III

That's totally awesome! I've been looking forward to trying this all weekend!

But, now that I have, I get this error: Object reference not set to an instance of an object

I don't see anything in the match fields dialogue where I would set the object reference. What am I missing?

Reply
0 Kudos
Highlighted
Occasional Contributor III

Well, I just tried Appending the data through the table on the Data tab and it worked like a charm!

Reply
0 Kudos
Highlighted
New Contributor III

Hi James,

I too ran into an issue where I needed to move some data and this worked nicely. The only problem I ran into is my photos/jpg attachments are not found in my appended data. I used the method you described and I am wondering if there is a way to get these photos moved with the data? Thanks.

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Hi Doug,

Unfortunately, the ArcGIS Online interface doesn't support attachments.  I would suggest appending with ArcGIS Pro instead.

Highlighted
New Contributor III

Hi James,

Is there also a way to append when having relative tables including attachments (derived from repeat questions)? I couldn't manage to do it so far. Your help is appreciated.

Kind regards,

Tijs

Reply
0 Kudos
Highlighted
New Contributor III

Good suggestion, I will defiantly give that a try. It would resolve a huge issue for me if it solves my problem. 

Reply
0 Kudos