Latest updates cause forms with nested repeats to hang when using launch links

939
4
Jump to solution
05-10-2022 07:42 AM
DougBrowning
MVP Esteemed Contributor

Reports from the field and we can recreate it.

After the latest Field Maps and 123 updates now when we launch a form from a URL in Field Maps, and that form has a nested repeat, the form hangs on Loading survey.  Then eventually you have to go back to the home screen and about 15 seconds later it says 123 has crashed.  Forms with no nested repeats it still works.

Log attached.

We are currently stuck and thus down.  

Thanks!

0 Kudos
1 Solution

Accepted Solutions
JamesTedrick
Esri Esteemed Contributor

To update this thread, in reviewing @DougBrowning 's form the issue appears to be the combination of a calculation question with the position() function within the nested repeat.  As a workaround, the question can be converted to an integer (or other appropriate type) question with a hidden appearance.

View solution in original post

4 Replies
JamesTedrick
Esri Esteemed Contributor

Hi @DougBrowning ,

The log file you provided is using a beta version of Survey123.  Are the field users using the beta version or the released production version?  The log indicates that this is the Lotic Transects survey- have there been any major changes since you last shared it with us in February?

0 Kudos
DougBrowning
MVP Esteemed Contributor

Yes my tablet is the beta 123but users are the latest release of both Field Maps and 123.  I tested 123 previous beta, Field Maps current release and Field Maps beta.  It seems to have been the last update in the play store but we are unsure if it was Field Maps, 123 or some combo at this point.  We cant really test updating more tablets since then we lose them from use.  Pre this latest update cycle these 3 forms have been working for 2 years or so.  Plus was working the last few months no problem.  No recent changes.  Still seems to be only nested repeat forms.  

Just tested on a Android testing tablet (iPad above) and with Field Maps 22.1.2 and 123 3.14.255 it is not working either.  First use of form so stuck on optimizing.  If I have opened the form before it sticks on Loading survey.

Reached out to another group and they have a single form with a nested but it is still working.  Still testing.

thanks

0 Kudos
DougBrowning
MVP Esteemed Contributor

Got a user to test.  iPad regular running 15.4.1.  So far all iPads and Androids seem to have the same issue.

Started with Field Maps 22.1.0 and 123 3.14.242 and forms all work fine.

Updated to Field Maps 22.2.0 and forms still work.

Update to 123 3.14.255 and then the forms hang.  Exact same map and form.

Hope that helps.  Trying to find more but when I do this then the user loses their tablet for good.

Opening the form directly still works fine.

Thanks

0 Kudos
JamesTedrick
Esri Esteemed Contributor

To update this thread, in reviewing @DougBrowning 's form the issue appears to be the combination of a calculation question with the position() function within the nested repeat.  As a workaround, the question can be converted to an integer (or other appropriate type) question with a hidden appearance.