Issues with web browser only survey

370
8
09-17-2017 08:06 PM
Highlighted
New Contributor III

I encountered few hurdles while trying to deploy a web browser only survey based on hosted feature service. 

1) Sign in/out buttons : The survey is deployed  as expected and both hosted FS and the survey is made publicly available.  Yet on the survey form in the browser a sign in and a print button is visible. 

This could confuse the general public taking part in the survey and I want to remove the two buttons, how to achieve this?

2) Image/logo: I would like to use the organisational logo at the top of the survey. 

If I use note or any other field type (read only) first it generates a blank space as noted in this known bug and second if a media image is used, it always shifts to the left margin of the web based survey. If the survey is open in survey123 app, the image is adjusted to center margin. 

Is the the known issue as well?

How to achieve this?

Thanks

Amit

Reply
0 Kudos
8 Replies
Highlighted
Esri Regular Contributor

Hi Amit

Could you let me know where you authored your survey - connect or the web designer?

1) I would expect to see the sign in box for a public surveys published in Connect (but not in a form created in the web designer). 

2) In the web designer - you can use the survey description to add a logo to the form. You can add in a link/url to an image or logo by pressing the insert image button when in design mode (with the survey description highlighted).

3) The note bug in the web form will be resolved as of 2.4 (released this week).

4) Please provide an example of the media image shifting to the left margin and also provide the dimensions of the image you are using. I will see if I can replicate. 

Thanks

John

Reply
0 Kudos
Highlighted
New Contributor III

Thanks for the reply Johnathan, 

The survey I am working on is authored using survey - connect as:

1)The survey uses hosted feature service in AGOL, not possible using web-designer. 

2) Survey expected to capture multiple fields hidden from the public. Hiding the fields is not possible in web designer. 

This is a test survey created in survey-connect and published as browser only 

A) Survey previewed in survey connect (The organisational logo appears in the center as expected)

2) Same survey published and viewed in the browser. 

The logo shifts to the left margin. 

The logo is PNG image with dimensions are 134 X 108 pixels (as standard organisational template)

same results for JPG image. 

Thanks,

Amit

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Thanks Amit

I have replicated the issue and have raised it as a bug.

Cheers

John

Reply
0 Kudos
Highlighted
New Contributor III

Great, 

Thanks for the help. 

Could you also replicate another issue?

Map option : Irrespective of map option set in Survey-connect, (world topography in my case), The browser always shows world street map as default. 

Accessing the survey through app would honor the default map option. 

Amit

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Hi Amit

The web form does not currently honour the basemap set in connect. We do have this open as an enhancement request.

Thanks

John

Highlighted
New Contributor III

Great, 

Thanks, 

Reply
0 Kudos
Highlighted
Esri Contributor

Looking forward to seeing this enhancement.

Highlighted
New Contributor II

We would also like to be able to choose the 'World Topography' basemap, rather than the Streets basemap, in a form generated using Survey123Connect.