Inbox Filter Popup works Online but not Offline

1139
12
04-25-2023 07:14 AM
Adam_Bourque
Occasional Contributor

Hello everybody, 

Background info: My popup button is a code to open and edit the existing point with inbox method they click on and will pass over / filter by address. It works no problem online, but the filter function does not seem to work with the inbox offline, after I click the popup button offline it opens survey123 form without the exact feature from field maps and then generates "error 0". Here is my code , any thoughts? I definitely need this workflow to work offline..  Both my web map is offline downloadable, no issues and the survey itself with feature layer. Full editing access with update, add, and delete.

------------

TESTING THIS FOR OFFLINE

 

Currently instructing them to "Refresh inbox" and solely use S123 for offline usage, but limits them from using the map pop up method like online..

<p><a href="arcgis-survey123://?itemID=14505fc4d195405aa06de1ee200a8e9e&action=edit&folder=inbox&update=true&filter={address}"><img class="image_resized" style="width:54.83%;" src="https://dabuttonfactory.com/button.png?t=Service+Line+Survey&amp;f=Roboto-Bold&amp;ts=22&amp;tc=fff&..." alt="Service Line Survey"></a> <span style="color:#ffffff;font-size:large;"><font style="background-color:rgb(220, 20, 60);"><strong>{expression/expr3}</strong></font></span><span style="color:#000000;font-size:large;"><font style="background-color:rgb(255, 215, 0);"><strong>{expression/expr5}</strong></font></span><span style="color:#ffffff;font-size:large;"><font style="background-color:rgb(128, 128, 128);"><strong>{expression/expr4}</strong></font></span><span style="background-color:rgb(65,105,225);color:#ffffff;font-size:large;"><strong>{expression/expr6}</strong></span></p>

---------------------

NOTE: I am currently relying on the q:GlobalID={GlobalID} passover for online workflow, trying to update with offline workflow with the filter and refresh inbox option.. explained by @JamesTedrick https://community.esri.com/t5/arcgis-survey123-questions/open-specific-survey-in-survey123-inbox-fro... 

My working online code... using q:Global IS BELOW

 

<p>

<a href="arcgis-survey123://?itemID=14505fc4d195405aa06de1ee200a8e9e&action=edit&folder=inbox&update=true&q:GlobalID={GlobalID}"><img class="image_resized" style="width:54.83%;" src=" https://dabuttonfactory.com/button.png?t=Service+Line+Survey&amp;f=Roboto-Bold&amp;ts=22&amp;tc=fff&..." alt="Service Line Survey"></a> <span style="color:#ffffff;font-size:large;"><font style="background-color:rgb(220, 20, 60);"><strong>{expression/expr3}</strong></font></span><span style="color:#000000;font-size:large;"><font style="background-color:rgb(255, 215, 0);"><strong>{expression/expr5}</strong></font></span><span style="color:#ffffff;font-size:large;"><font style="background-color:rgb(128, 128, 128);"><strong>{expression/expr4}</strong></font></span><span style="background-color:rgb(65,105,225);color:#ffffff;font-size:large;"><strong>{expression/expr6}</strong></span></p>

 

------------

 

0 Kudos
12 Replies
ClayDonaldsonSWCA
Occasional Contributor II

have you been refreshing the inbox before going offline?

0 Kudos
Adam_Bourque
Occasional Contributor

Tried both ways, to refresh inbox before going online and completing wiping out the inbox.. with the online it would auto refresh and be in the "inbox screen" when using mode=edit ; action=edit will open that record directly. 

0 Kudos
Adam_Bourque
Occasional Contributor

 @Ismael  @JamesTedrick any solutions here for offline? I know James you seem familiar with this workflow. Didn’t know if there’s a way even if I have the employees preload the inbox manually if could get this to work with offline. Considering sending to outbox if that would work too but need it to edit existing points.

0 Kudos
BarbaraWebster1
Esri Regular Contributor

@Adam_Bourque I'm seeing the same error when I include 'update=true' in an offline environment. It looks like 'update=true' is not being ignored when offline. I created an internal issue for this but you may want to file a support issue as well to be able to receive updates. 

As a workaround you could either remove the 'update=true' parameter and ask users to be sure to refresh the inbox at the beginning of the day, or you could create two buttons, one that will update the inbox automatically and one that won't that can be used in offline environments.

Thanks,
-Barbara

0 Kudos
Adam_Bourque
Occasional Contributor

Thank you for the quick response @BarbaraWebster1 I have resulted in doing just that but instead of two buttons having an "offline" and "online" map with the popup. Can I file a support issue online or do I have to call to do that? Staying extra busy with the Lead inventory rule helping water utilities, so really would appreciate if there is a fix to this in the near future. I will do what I have to do to get it to work, am very grateful for these survey123 functions when they can work in offline environments as we serve many rural remote disadvantaged utilities. 

BarbaraWebster1
Esri Regular Contributor

Glad to hear you found an approach that will work. It's possible to file a support case online, although the support analyst may request a call so they can confirm the workflow and make sure they can reproduce the issue on their end. 

Thanks,
-Barbara

Adam_Bourque
Occasional Contributor

Thank you Barbara, I was able to create a case and report a bug using representative I worked with prior, Jordyn. For anybody's interest of this topic to folow up the bug # is below. Thank you ESRI team for responding to this.

  • BUG-000157932 : Unable to refresh inbox in Survey123 when working offline and using a pop-up link to edit an existing submission.
Adam_Bourque
Occasional Contributor

Is there a way to follow up on bug # / case #? I would still like to see this workflow function offline if possible.

  • BUG-000157932 : Unable to refresh inbox in Survey123 when working offline and using a pop-up link to edit an existing submission.
0 Kudos
BarbaraWebster1
Esri Regular Contributor

Hi @Adam_Bourque,

A fix for this bug was included in the Survey123 August update. If you update to the most recent version of the field app is the issue resolved?

Thanks,
-Barbara

0 Kudos