External Selects Not Working in Web Form

126
2
02-19-2019 06:02 AM
Highlighted
Occasional Contributor

A staff member of mine has published a two surveys; one Web one mobile/desktop. Both are using external selects (three levels) and use the same XLS Form code to access the select. The external select worked on Web form when published in Connect v. 2.5.44, but fails when published in a later version. We can navigate through levels 1 and 2 before it fails on level 3, the available selections are blank. It should be noted the survey works on mobile and desktop using the same code.

Is there a new limitation on levels of selects that can be performed using the Web form? We are going to try removing the external and try a cascade select to see if it works. I have attached the Excel file for the Web form.

Any help you can provide is greatly appreciated,

Chris Anderson

Florida Fish and Wildlife Conservation Commission

Reply
0 Kudos
2 Replies
Highlighted
Esri Regular Contributor

Hi Chris,

I can see the behavior with your specific XLSForm, where there is an empty select dropdown menu for your "Species" selection.

I have tested with several other forms which include multiple select_one questions that reference values in the external_choices sheet, and have not had any issues.  How did your test with the cascading selects go?

While we continue to troubleshoot, one method that you can use for viewing the functioning selection for Species is to use a parameter to specify the web app version.  So, as an example

https://survey123.arcgis.com/share/a8ee16c9775e429f915cc90677255019?version=3.0

Best,

Brandon

Reply
0 Kudos
Highlighted
New Contributor II

Hi Brandon, 

I'm encountering the same issue that Chris had. I tested the method you suggested as workaround (adding a parameter to the web for URL version=3.0) and it works fine.

I'm wondering if meantime, you found out how we can address this issue without having to add the URL parameter?

Many thanks

Reply
0 Kudos