Error Power automate (flow) con la version 3.12

581
6
03-08-2021 11:27 AM
Analista_SigEoa
New Contributor II

esponseSwaggerSchemaValidationFailure. La API "survey123" devolvió una respuesta no válida para la operación de flujo de trabajo "Cuando_se_envía_una_respuesta_de_encuesta" de tipo "OpenApiConnectionWebhook". Detalles del error: "La operación de la API "AddData" requiere que la propiedad "body/feature/attributes/Dias" sea de tipo "String", pero es de tipo "Integer"."

 

me sale este error cuando envío mi encuentas.

Me pdrian ayudar a solucionarlo esto esta pasando con la nueva actualización de la aplicación de campo

 

Mi email es wicho062@gmail.com

gracias

0 Kudos
6 Replies
Analista_SigEoa
New Contributor II

Buenas tardes.

 

1. La versión de survey123 con la que estoy publicando el formulario es 3.11.123

2. La versión de la aplicación es 3.12.274

3. El error aparece al inciar el flujo en Power Automateerror 2.JPGerror 1.JPG

 

 

0 Kudos
IsmaelChivite
Esri Notable Contributor

Hi @Analista_SigEoa   Despues de analizar su documento XLSForm en detalle, le comparto lo siguiente:

  • El error esta causado por un cambio en la version 3.12. Estamos investigando como se podria arreglar el problema.
  • De momento, le sugiero lo siguiente:
    • Inserte una nueva pregunta, inmediatamente despues de la pregunta dias con las siguientes caracteristicas: type=calculate  name=dias_texto label=dias_texto calculation=${Dias}
    • Guarde cambios y publique el formulario. Survey123 Connect le pedira autorizacion para crear un nuevo campo en la capa de entidades. Acepte. No perdera ningun dato.
  • En Power Automate, utilize el nuevo campo dias_texto
0 Kudos
Analista_SigEoa
New Contributor II

Sr Ismael buenas tardes, realice el procedimiento que me indico y sigue presentando el mismo error, lo que hice fue desinstalar la versión de mi móvil de 3.12.274 a la versión 3.11.164 y así  si me funciona.

lo otro que pienso realizar es actualizar el Survey 123 connect de la 3.11.123 que tengo a una mas actual a ver si asi me funciona.

ya que las otras encuentas que tengo ya publicadas y se trabajan con la ultima versión movil de survey123 3.12.274 funcionan sin problemas.

Quedo atento a sus orientaciones.  Gracias

 

 

0 Kudos
juan_luisGarcia_González
New Contributor II

Hi, @IsmaelChivite , nosotros hemos tenido el mismo problema a raiz de la entrada de la versión, 3.12, pero en nuestro caso es al contrario:

ResponseSwaggerSchemaValidationFailure. La API "survey123" devolvió una respuesta no válida para la operación de flujo de trabajo "Cuando_se_envía_una_respuesta_de_encuesta" de tipo "OpenApiConnectionWebhook". Detalles del error: "La operación de la API "AddData" requiere que la propiedad "body/feature/repeats/PersonalTarea/0/attributes/Act2Imp" sea de tipo "Number", pero es de tipo "String"."

Te adjunto una captura del error y del json donde se ve que a un campo numerico le ha incluido unas comillas dobles (string).

 

 

Captura.PNG

 

Saludos

0 Kudos
Analista_SigEoa
New Contributor II

Buenos días, a mi para que me funcione me toco volver a instalar el 3.11 y ahí no eh tenido mas ese problemas hasta que Esri lo solucione ya que no podemos para el trabajo de recolección de datos en la Empresa

juan_luisGarcia_González
New Contributor II

Buenos dias, hay alguna novedad respecto a este error, o existe alguna manera de evitarlo que no pase por volver a una versión anterior de Survey.

Saludos

0 Kudos