Cannot send surveys

439
3
Jump to solution
09-21-2021 03:48 PM
KathyBaker-Brosh
New Contributor II

I have a survey that is hooked up to an existing feature service. I keep getting an error when I go to submit the survey, but it doesn't tell me why. When I sign in to update where to ope the survey (browser or app) it gives me this error, which may or may not be related. Help!

 

{"error":{"name":"ArcGISRequestError","message":"400: Unable to update feature service definition.","originalMessage":"Unable to update feature service definition.","code":400,"response":{"error":{"code":400,"message":"Unable to update feature service definition.","details":["Invalid definition for 'Capabilities'.","Invalid definition for System.String"]}},"url":"https://services8.arcgis.com/ZqR4BTHXyzfVaMty/arcgis/rest/admin/services/Tidal Saggitaria Survey/FeatureServer/updateDefinition","options":{"httpMethod":"POST","authentication":{"username":"OtterPointCreek","token":"ZHkIyol-OZnCsZ_8OwNwojr9SMUNMoVaZyIXVkTZEwGQaqheeojNlQ8wgNCSJ0vQ-tnsyqeD8j1Wi1taKh6CTW8ZRNbeITT0EF_YrEeMjmRlH6B6_UpaLRokaePsJG3ebQ834xrCM6nRweWfjfpEbISVoZblk5F0-mgNDMHSKm7gHmIgqABGj71MFRITPviIslmjU7qfWHGDUubx9DfTMTxMoQ6FpzJc_X0kGB2ZFco.","tokenExpires":"2021-09-22T08:05:24.932Z","portal":"https://www.arcgis.com/sharing/rest","ssl":true,"tokenDuration":20160,"refreshTokenTTL":1440},"params":{"updateDefinition":{"capabilities":"Create"}},"headers":{}}}}

0 Kudos
1 Solution

Accepted Solutions
KathyBaker-Brosh
New Contributor II

Found the issue. The existing feature service was not editable!!

View solution in original post

0 Kudos
3 Replies
KathyBaker-Brosh
New Contributor II

It also appears that I get the same error when I go to change what submitters can do - so far, none of the bubbles can be selected for what a submitter can do, which I am assuming is why I can't submit.

0 Kudos
KathyBaker-Brosh
New Contributor II

Found the issue. The existing feature service was not editable!!

0 Kudos
ShariForbes
New Contributor III

Hello. I'm getting a barely slightly different error. I just verified that my feature service is editable. Do you think I need to create a new proxy service for my forms? 

{"error":{"name":"ArcGISRequestError","message":"GWM_0002: Invalid URL","originalMessage":"Invalid URL","code":"GWM_0002","response":{"error":{"code":400,"messageCode":"GWM_0002","message":"Invalid URL","details":[]}},"url":"https://utility.arcgis.com/usrsvcs/servers/12eed957d1224be496424810f414adf5/rest/admin/services/BEST...","options":{"httpMethod":"POST","authentication":{"username":"shariforbes","token":"UfivxqHNeN_cK8mqlkG9QV5grf-jIye-HL6PO0NJzX8lh39U8mrhNuTrfzRop112TgMXbT9CT-U_yuW3eUIPm-Wg0aeiJB_tBQ48Xo4O7ixuHRoczheHmhfuH1Le9Ri0UCu_y92Oj1vqRSW6zx2gypEtMaL3OxaG_aI6pfFwDca5R9w9dcga_py3xHRNHTCVs7mY3SmyRG3hm3-rIRk2LayjzFwyOTWJq1tirdpOL5U.","tokenExpires":"2021-09-30T07:35:17.413Z","portal":"https://www.arcgis.com/sharing/rest","ssl":true,"tokenDuration":20160,"refreshTokenTTL":1440},"params":{"updateDefinition":{"capabilities":"Create,Uploads,Editing,Sync"}},"headers":{}}}}

0 Kudos