Bundle Validation Error Survey123 and Integromat

1799
7
03-01-2022 01:06 PM
Labels (1)
SWilander
New Contributor III

I have this Survey 123 and Integromat scenario setup like this: What is the problem with the S123 when I get the BundleValidation Error and states it needs a valid URL?

SWilander_2-1646168487230.png

 

SWilander_0-1646167994967.png

I am getting a BundleValidation Error in integromat at the Get a File HTTP Module, and when I look at the settings I see nothing in the fields. 

SWilander_1-1646168283286.png

Does anyone know where to fix this in the Survey123 -survey? Thanks!

0 Kudos
7 Replies
DerrickWestoby
Occasional Contributor III

It looks to me like you have a pipe character ( | ) just before your URL in the "Get a File" module.  Try removing that.  

I think that's your issue, but if it's not....make sure that your report was actually successfully generated by the "create a report" module.  After you run it, click in the "1" bubble above the module and expand the result files group to make sure a URL is actually being provided. 

0 Kudos
SWilander
New Contributor III

Hey thanks Derrick. That was just my cursor not a a pipe. Great eyes though. I ran the single module and get these results, 2 screenshots below

SWilander_1-1646250980379.png

 

SWilander_0-1646250893387.png

 

0 Kudos
DerrickWestoby
Occasional Contributor III

Ahhhh, that looks like your "Create Feature Report" module wasn't set up correctly. Should be a quick fix: 

Make sure you're drawing from the correct spot in the "Watch Webhook" module for that objectId, and also double check that your connection, survey and report template are correct. 

DerrickWestoby_0-1646251240072.png

 

SWilander
New Contributor III

Thanks Again,

well I have selected all the right files in the interface, connection, survey and report template are correct.  Then I selected the features result objectid (Mapped it). But I show no payload urls in the interface like in the screen cap below. And I dont know how to fix that issue. Do you? Where to click what -I am literally 5 days into this app and issues.

SWilander_0-1646334839437.png

 

DerrickWestoby
Occasional Contributor III

I'd need to see the result of the scenario running to make a guess, if what you have here isn't working (your screenshot looks correct).   

This probably isn't an issue, but just to rule out a few potential problems....delete what you have entered in "Output Report Name".  

Save your scenario, click "Run Once" in the bottom left, and then send in a test submission.  
My screenshot below is what what I need to see in  your scenario.  "Details" should give you an error message if the report fails to generate, and that error message is  your clue.  If the report succeeds to generate, you'll see the URL to download it like in my screenshot

DerrickWestoby_0-1646335512648.png

 



0 Kudos
SWilander
New Contributor III

I found this to work for me.

Integromat or Make Errors: BundleValidationError, Missing URL, ….Wont Pass Filter

FIX IN INTEGROMAT also known as MAKE, “Scenario”:

Leave the “Advanced Settings” checkbox UNCHECKED in the Integromat -Survey123 Create Report Module and save the Integromat Scenario.

At this time this issue is related to the Feature Layer which is in your ArcGisOnline (AGO) Content for the Survey. In this case I had two Feature Layers in the AGO Survey’s Content. And If I had the “Advanced  Settings” checkbox on, I would be able to chose which feature layer was included in the Create a Report Module, which causes the whole Scenario to FAIL at this module. Leaving the Advanced Settings checkbox unchecked somehow allows the Scenario to Include both of the feature layers in the scenario allowing the whole scenario to run with success.

A repeat of this fix; In the end the fix for this was in the Survey123 Create Report Module in the Integromat scenario, and to -leave off the checkbox for Advanced Settings and save the Module with this box UNCHECKED.

SWilander_0-1646760143004.png

 

0 Kudos
Sharouff
New Contributor II

I am having this same issue and in trying to turn off advanced settings in the create feature report module I am unable to save after flipping the switch to turn off. I get a purple box around the OK button but it doesn't save.  I tried Refresh at the top of the module and even logging out and back into Make.

Did you have this additional issue or were you able to turn off advanced setting and your scenario is now running as it should?

0 Kudos