Layer name not updating in StoryMaps legend

213
2
07-06-2021 10:58 AM
SimmonsArielle
New Contributor

Hi!

I think the bug that was solved last year is back [1].

I am facing a similar issue wherein I don't see the layer name updating in my storymap's legend. (Please refer to bug1.jpg)

I had renamed the layer as shown in images (bug2,jpg and bug3.jpg)

Can you please help me out in understanding if it is the same bug or am I doing something differently than I'm supposed to in order to update the names in the legend.

Looking forward to hearing from you soon.

Thanks, Ari

 

1: Solved: The layer legends are not updating correctly when ... - Esri Community

0 Kudos
2 Replies
GISWisDom
New Contributor

I am also having this issue when I edit the layer name in both map viewer classic and the new version. I have even changed the name of the original layer and this is also not updating in the storymap.

Is there or has there been a solution identified?

 

Thanks

0 Kudos
OwenGeo
Esri Notable Contributor

@GISWisDom -- This isn't something that we have addressed yet, but it is on our list to try to provide a way to refresh layer names if you want them also to change within a story when they are changed in the underlying web map.

For now, you could disable the legend on the map and add it as a screenshot in the narrative panel of the sidecar. Or I'd also encourage you to see if you can eliminate the legend through some other creative storytelling by using colored text or other descriptive information in the sidecar, as described in this story.

Owen Evans
Lead Product Engineer | StoryMaps
0 Kudos