Intense lags when using sidecar immersive

130
1
11-29-2021 08:24 AM
PlantPestSurveillancePROJECT
New Contributor II

We have been recently adjusting to the new StoryMaps format and for our outputs we need to use the sidecar option almost exclusively, 

After about 15 slides in, when images and maps are uploaded, we experience heavy lags from the application, multiple crashes and a general unresponsiveness from the site,

 

Could you provide some insight on this?

Tags (2)
1 Reply
OwenGeo
Esri Notable Contributor

@PlantPestSurveillancePROJECT -- I apologize that you are having a problem with your story. We have tested ArcGIS StoryMaps with more than 15 slides of maps and images in a single sidecar without seeing the issue you've described, so it might be something specific with your story content.

Please contact Esri Support and they can help troubleshoot this with you.

From a storytelling perspective, however, I wanted to mention that it's not usually ideal to have very long sidecars. Most readers will get fatigued having to scroll through slide after slide, and they will become less engaged with your story. For most cases, we recommend six slides or fewer in each sidecar, and it would be a very rare case where using more than 10 slides would provide a good experience.

Even though you should be able to have that many slides in your story without an issue, are there other ways you can tell your story so the reader doesn't need to scroll through 15+ slides in a row? Can you break up the content into multiple sidecars to give the reader a rest at certain places in the story? Can you use map actions to keep the reader engaged and provide an interactive experience within the same slide? It might be helpful to think about designing your outputs in other ways to keep the reader engaged since there are many different storytelling blocks available to use within the same story in ArcGIS StoryMaps.

Owen Evans
Lead Product Engineer | StoryMaps