Spatial Analyst Minus Error

3569
3
Jump to solution
09-05-2014 06:51 AM
DavidMeek1
New Contributor III

Hi all,

Trying to use the Spatial Analyst "Minus" tool and cannot get it to function properly.  My basic system is:

ArcGIS 10.1 SP1 (Build 3143)

ArcMap 10.1

Windows7 Enterprise SP1

I have two grids, one of which I am trying to subtract from the other.  I can display both and generate contours from both so I am assuming there are no gross errors in the data.  When I bring up the tool bar, select Minus, fill out the three parameters and hit OK, I get the following results.  Any help in resolving this will be greatly appreciated.

David

0 Kudos
1 Solution

Accepted Solutions
TimothyHales
Esri Notable Contributor

Similar error in No spatial reference exists Minus and Raster Calculator‌ which points to coordinate system as Dan mentioned.

Also, I've moved your post into the Spatial Analyst space. You will get a much better answer here as the GeoNet Help is intended for community help and feedback. You can see more on the community structure, and what topics are under each space from the following documents:

GeoNet Community Structure

ArcGIS Discussion Forums Migration Strategy

Thanks!

Timothy

View solution in original post

0 Kudos
3 Replies
DanPatterson_Retired
MVP Esteemed Contributor

The files are in the same coordinate system?  The error says you have an empty geometry problem...so ensure the files are in the same coordinate system and of overlapping extent etc.

0 Kudos
TimothyHales
Esri Notable Contributor

Similar error in No spatial reference exists Minus and Raster Calculator‌ which points to coordinate system as Dan mentioned.

Also, I've moved your post into the Spatial Analyst space. You will get a much better answer here as the GeoNet Help is intended for community help and feedback. You can see more on the community structure, and what topics are under each space from the following documents:

GeoNet Community Structure

ArcGIS Discussion Forums Migration Strategy

Thanks!

Timothy

View solution in original post

0 Kudos
DebraParthree
New Contributor II

I was getting the same 3 errors repeatedly after performing the Minus function (and also using the Reclassify tool) the same way I always do with no errors.  I restarted ArcMAP and it worked perfectly with no errors.  These kinds of errors should not happen.  I was doing nothing wrong and the software malfunctioned.  I wish I was making the salary of these software developers that can't seem to get it right before putting it on the market and making a buck!

0 Kudos