Large cell size after using raster calculator

3605
7
Jump to solution
03-26-2015 02:28 PM
DitlevReventlow
Occasional Contributor II

Hey Everyone.

I am multiplying two raster layer with each other using raster calculator in ArcGIS. One of them have a much coarser spatial resolution than the other.

I thought that the resulting raster cell size would be corresponding to the layer with the finer resolution because in my head this would make sense (the value of the bigger cell is simply multiplied to all the smaller cell yielding different small cells).

But when I perform the operation, the resulting cell size is corresponding to the raster layer with the coarser resolution.

How can this be? And is there some way to make the resulting raster having the finer resolution.

Thank you!

Regards,

Ditlev Reventlow.

0 Kudos
1 Solution

Accepted Solutions
JayantaPoddar
MVP Esteemed Contributor

As mentioned by Dan,

In Raster Calculator dialog box, Go to Environment Settings

Set the XY resolution, as desired.



Think Location

View solution in original post

7 Replies
DanPatterson_Retired
MVP Esteemed Contributor

No, it sometimes uses the first, set the cell size in the Environments tab of the tool

DitlevReventlow
Occasional Contributor II

Sorry, I am not sure where this is, where is tool?

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

​I assumed you were using arcmap 10.x... it is here ArcGIS Help (10.2, 10.2.1, and 10.2.2)  bottom of the dialog

JayantaPoddar
MVP Esteemed Contributor

As mentioned by Dan,

In Raster Calculator dialog box, Go to Environment Settings

Set the XY resolution, as desired.



Think Location

View solution in original post

DitlevReventlow
Occasional Contributor II

Ahh okay, didn't see that small menu. Thank you very much!

0 Kudos
MattSchelly
New Contributor

I, too have the same problem, however with simple addition of rasters, not multiplication.  All 6 of my rasters have a 50-foot x 50-foot cell size and when added together they create a raster with a 264-foot cell size.  All 6 have been clipped to the same extent, but the rasters were created from polygon features and so they are not all exactly aligned with each other.  I used the Environment setting for XY Resolution and Toerance, but the result was 264-foot cells.  

Why? Or better, how do I get 50-foot cells in my result?  Thanks!

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

you need to set the cell size to the desired value and the analysis extent to the union of the inputs otherwise you get a default calculation of 1/250 of the maximum of the extent width an height.  In short... if you don't set things explicitly, you get a default derived from what is thought best.