Crowdsource Polling Error: commentAddFailed

789
7
12-11-2018 12:19 PM
KyungahLim1
New Contributor

Hello,

The comments worked previously but all of the sudden the application is giving me an error when I try to submit a comment. The error says commentAddFailed. Can someone help me figure out what the error is about?

I pretty much followed the instructions described in https://solutions.arcgis.com/local-government/help/crowdsource-polling/ to use this Crowdsource Polling web application.

I had a file geodatabase that contained a feature class with GlobalID and a related table with a foreign key in guid format.

I then compressed that geodatabase and uploaded and added in a web map, in which I configured the pop ups and symbology.

This link goes to the web application: https://grantworks1.maps.arcgis.com/apps/CrowdsourcePolling/index.html?appid=374cab94dce24150b196e1d... 

0 Kudos
7 Replies
AllisonMuise1
Regular Contributor

Kyungah Lim‌ I was able to submit a test comment in your application without error. Are you still having this issue?

0 Kudos
CoreyKlawunder
New Contributor

Hello, I am also having this issue.  I have two accounts - the commenting application works on my enterprise account, but on my personal developer account I get the message "commentAdd failed".  Could you please advise?  

0 Kudos
AllisonMuise1
Regular Contributor

This error is usually displayed when there is an issue with the relationship between the comment table and the feature layer. If you can share the URL to the app, I'd be happy to take a look at it for you.

0 Kudos
CoreyKlawunder
New Contributor

Thanks for your prompt response! Fortunately I fixed the error.  Turns out I had neglected to enable editing on the feature layer in my developer account - having two accounts will confuse you like that I suppose.  Cheers!

0 Kudos
JenniferZhan
New Contributor

Hi Corey. I just want to follow up with your solution here. How did you enable editing feature layer? Do I need to have a developer account for that? Thank you!

0 Kudos
CoreyKlawunder
New Contributor

Hi Jennifer, happy to help.  So starting from the Manage Content page, click on the hosted feature layer to go to the details page for that item.  Then at the top right click settings.  Scroll down on this page down to the area called "Feature Layer (hosted)" and check the box next to "Enable Editing".  Be sure you've got everything set to be shared with everyone too.  I'd post pictures here but I don't want to expose my data to the greater public.  I'm not sure if you need to have a developer account or not, but if you do they are free. 

Email me at corey.klawunder@aecom.com if you'd like further assistance, I'd be happy to help! And I'm interested in the map you're making - I work at the AECOM office in Atlanta, so we have some overlap.  Cheers!

0 Kudos
JenniferZhan
New Contributor

Hi Allison, I have the same issue with not being able to comment or vote. Here is my app https://mmp.maps.arcgis.com/apps/CrowdsourcePolling/index.html?appid=08f240c28ecd4c05a0d1cdef98ff3b8.... Could you help me debug this? Thank you very much!

0 Kudos