ArcGIS Runtime for Qt Mac Plugin Error

2573
4
Jump to solution
08-24-2015 12:20 PM
CeyhunYilmaz
New Contributor III

Hi everyone,

I have a problem with Arcgis plugin on Mac OS. After I succesfully installed SDK and plugin for IOS 5.5, clang 64 bit and Qt Creator (with post installer), I created a new Arcgis Runtime project 10.2.6 and I selected clang 64 bit, IOS 5.5 kits to build it. But in main.qml file there is an error on "import ArcGIS.Runtime 10.26" . Error says that "Qml Module not found ".

Thanks.

0 Kudos
1 Solution

Accepted Solutions
CeyhunYilmaz
New Contributor III

Hi Lucas,

I solved problem. I downloaded 5.4.2 kits and re-ran ArcGIS post installer for them. Then when built my project with these ,it works.

Thanks

View solution in original post

0 Kudos
4 Replies
LucasDanzinger
Esri Frequent Contributor

Hello,

Are you trying to build and run for Mac or iOS? I see from your notes that when you created the app, you selected Mac (clang 64) and iOS. Do you see this error when you select Mac or iOS or both?

Typically the only thing you should need to do is run the post installer and point it to the desired versions of Qt. Once you do this, you should notice in your Qt kit, that there will now be an ArcGIS folder in the following location (<qt_install_path>/Qt/clang_64/qml/ArcGIS). If this folder does not exist, re-run the post installer. If it does exist, make sure you are selecting the proper kit from Qt Creator.

Thanks,

Luke

0 Kudos
CeyhunYilmaz
New Contributor III

Hi Lucas,

I checked what all you said me before you replied.

/../qml/ArcGIS folder is exists. I build with clang 64 bit kit and IOS kit both. Both of them give same problem me.

I send you attachment that maybe helps you to understanding problem

http://s000.tinyupload.com/?file_id=03947904451916775292

http://s000.tinyupload.com/?file_id=06954963571772110821

http://s000.tinyupload.com/?file_id=00954076741786473336

What do you recommend to install or work Qt Creator and ArcGIS SDK versions for stable working?

Thanks.

0 Kudos
LucasDanzinger
Esri Frequent Contributor

Ceyhun-

In your the first screenshot it shows you using Qt 5.5, but in your second screenshot, the path you are showing in the Mac Finder window is 5.4. I think maybe you have a 5.4 kit installed as well and you ran the post installer against that one, and not the 5.5 kit. You need to make sure the ArcGIS folder exists under your 5.5 kit, not 5.4.

Thanks,

Luke

0 Kudos
CeyhunYilmaz
New Contributor III

Hi Lucas,

I solved problem. I downloaded 5.4.2 kits and re-ran ArcGIS post installer for them. Then when built my project with these ,it works.

Thanks

View solution in original post

0 Kudos