Strange crash within [AGSLocalTiledLayer batchTilesRequestOperationSucceeded:]

1162
2
05-06-2012 01:41 PM
TobyCox
New Contributor
We're occasionally seeing crashes within our app using the latest ArcGIS SDK.
It's a EXC_CRASH (SIGSEGV) on thread 0, but no code is running on thread 0 at the time (at least in the crash report).
The common theme with all of the crash reports we're getting is a call to [AGSLocalTiledLayer batchTilesRequestOperationSucceeded:]

Thread 8:
0   libsystem_kernel.dylib         0x352f0848 __kill + 8
1   OurApp                       0x00458c9a 0xa6000 + 3878042
2   libsystem_c.dylib              0x371f77e6 _sigtramp + 42
3   OurApp                       0x0011e7ea -[AGSEnvelope intersectsWithEnvelope:] (AGSEnvelope.mm:172)
4   OurApp                       0x00185352 -[AGSTiledLayerView addTiles:] (AGSTiledLayerView.m:1325)
5   OurApp                       0x00185a2a -[AGSTiledLayerView tiledLayer:operationDidGetTileBatch:] (AGSTiledLayerView.m:1421)
6   OurApp                       0x001db5a4 -[AGSLocalTiledLayer batchTilesRequestOperationSucceeded:] (AGSLocalTiledLayer.m:460)
7   CoreFoundation                 0x3545c1f4 -[NSObject performSelector:withObject:] + 36
8   Foundation                     0x313b3740 __NSThreadPerformPerform + 344
9   CoreFoundation                 0x354d1acc __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ + 8
10  CoreFoundation                 0x354d1298 __CFRunLoopDoSources0 + 208
11  CoreFoundation                 0x354d003e __CFRunLoopRun + 646
12  CoreFoundation                 0x3545349e CFRunLoopRunSpecific + 294
13  CoreFoundation                 0x35453366 CFRunLoopRunInMode + 98
14  Foundation                     0x31313b6e -[NSRunLoop(NSRunLoop) runMode:beforeDate:] + 250
15  OurApp                       0x00163652 -[AGSWorkerThreadUnit workerThreadMainRoutine] (AGSMapView.m:189)
16  Foundation                     0x3131fa7a -[NSThread main] + 66
17  Foundation                     0x313b358a __NSThread__main__ + 1042
18  libsystem_c.dylib              0x371ae72e _pthread_start + 314
19  libsystem_c.dylib              0x371ae5e8 thread_start + 0


I've attached the full crash report. Does anyone have any ideas?
0 Kudos
2 Replies
NimeshJarecha
Esri Regular Contributor
1. If possible, can you please attach your tpk file which is being used to create the AGSLocalTiledLayer along with sample code?
2. Any idea what scenario causes the crash? Map interaction? Zoom/Pan?

Regards,
Nimesh
0 Kudos
TobyCox
New Contributor
The TPK is 13GB, so can't really attach sorry.
I'm not sure what causes the crash, it's only ever our client seeing the problem.
I suspect it's when they zoom to a certain level.
What sort of issues in a Tile package might cause a crash like this?
0 Kudos