Layer-Locator gets not imported on Map Import

238
5
08-14-2017 03:13 AM
Highlighted
New Contributor

Importing a Map twice with a Layer configured as Locator:  On the second Import, when the first Map is still loaded in the project, the Locator of the second map gets not imported. This seems to be a Bug.

Tags (1)
Reply
0 Kudos
5 Replies
Highlighted
New Contributor

Steps to reproduce:

  1. Create New Project
  2. Add Map
  3. Add QueryLayer
  4. Add Locator with this query layer
  5. Save Map as map file
  6. import map -> Locator is not visible in locate pane

If the import is done on an empty project (no other map) the locator is visible

Reply
0 Kudos
Highlighted
New Contributor

As we use the map file as a template. We will have to set the locators new for every map > the first one.

Reply
0 Kudos
Highlighted
New Contributor

This problem exists since agp 1.4 / 2.0

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Bendicht:

We are aware of this behavior and will try to address the problem as soon as we can. In the meantime, I would suggest creating a Project Template ( the button is next to Map File on the Share tab) instead of the Map File and use the Project Template to create projects from that contains the feature and layer provider. See the following help topics:

Create a project template—ArcGIS Pro | ArcGIS Desktop 

Create a new project—ArcGIS Pro | ArcGIS Desktop 

Reply
0 Kudos
Highlighted
New Contributor

Thanks for the Reply. Because we alter the map template dynamically, we can't use the project template. As a workaround it would be sufficiant beeing able to add the Layer-Locator from Code, but i did not find any interface or samples doing this. This would help us a lot. I tried using the LocatorConfigurationManager but was not successful in using it.

Reply
0 Kudos